2d083b9113
Changes: Add a A- directory with sources that fix several bugs in the original code. Keep A+ to allow students to compare results Corrections and A- tree from mark P Sullivan (msulliva at stevens-tech dot edu) Corrections sent to the original author, but no response. Synch PLIST with reality.
22 lines
734 B
Text
22 lines
734 B
Text
$NetBSD: patch-ae,v 1.1 2002/10/04 16:39:41 jschauma Exp $
|
|
|
|
--- A-/Makefile.orig Fri Oct 4 11:55:58 2002
|
|
+++ A-/Makefile Fri Oct 4 11:57:53 2002
|
|
@@ -1,13 +1,12 @@
|
|
-CC = gcc
|
|
-
|
|
-CFLAGS = -Wall -ansi -pedantic
|
|
+YACC= yacc
|
|
+FLEX= flex
|
|
|
|
main: y.tab.o lex.yy.o main.o tree.h tree.o error.h error.o memory.h memory.o weed.h weed.o symbol.h symbol.o type.h type.o defasn.h defasn.o resource.h resource.o code.h code.o optimize.h optimize.o emit.h emit.o
|
|
$(CC) lex.yy.o y.tab.o tree.o error.o memory.o weed.o symbol.o type.o defasn.o resource.o code.o optimize.o emit.o main.o -o joos -lfl
|
|
|
|
y.tab.c y.tab.h: joos.y
|
|
- bison -y -d joos.y
|
|
+ ${YACC} -d joos.y
|
|
|
|
lex.yy.c: joos.l y.tab.h
|
|
- flex joos.l
|
|
+ ${FLEX} joos.l
|
|
|