f8a0903fc5
New Features and Changes: ======================== o The following Vdata routines were added: VSsetblocksize/vsfsetblsz -- sets the block size of the linked-block element. VSsetnumblocks/vsfsetnmbl -- sets the number of blocks for a linked-block element. VSgetblockinfo/vsfgetblinfo -- retrieves the block size and the number of blocks of a linked-block element. o Two routines were added to get compression information for the SD and GR interfaces, including chunked elements: SDgetcompress/sfgcompress and GRgetcompress/mggcompress. Note: - For a JPEG image, GRgetcompress only returns the compression type, not the compression information (i.e, quantity and force_baseline). This information is not currently retrievable. - Getting compression type for JPEG chunked images is not working yet. o "hdp dumpgr" has a new option, -pd, to print palette data only. Also, whenever option -p or -pd is given, only palettes are printed, and no images or file attributes. o A new FORTRAN function, heprntf (HEprint), was added. It takes two arguments: file name and level. If the file name string has 0 length, then error messages will be printed to standard output. o A memory leak in the netCDF portion of the HDF/mfhdf distribution was fixed. o The "#define NULL" was removed since ANSI C compilers are required to define NULL. o When using "hdp dumpgr", data was being printed in the range of 0-250 when it should have been between 0-168. This problem is now fixed.
31 lines
861 B
Text
31 lines
861 B
Text
$NetBSD: patch-an,v 1.3 2002/05/03 23:14:53 jtb Exp $
|
|
|
|
--- /dev/null Wed May 1 14:04:01 2002
|
|
+++ mfhdf/nctest/Makefile Wed May 1 14:14:41 2002
|
|
@@ -0,0 +1,26 @@
|
|
+PROG= nctest
|
|
+
|
|
+SRCS = varget.c vargetg.c varput.c varputg.c vardef.c vartests.c \
|
|
+ vputget.c vputgetg.c driver.c cdftests.c dimtests.c rec.c \
|
|
+ atttests.c misctest.c add.c error.c emalloc.c val.c slabs.c
|
|
+
|
|
+CPPFLAGS+= -Dunix -DNDEBUG
|
|
+CPPFLAGS+= -I${.CURDIR}/../../hdf/src
|
|
+CPPFLAGS+= -I${.CURDIR}/../libsrc
|
|
+
|
|
+LDFLAGS+= -L${.CURDIR}/../libsrc
|
|
+LDFLAGS+= -L${.CURDIR}/../../hdf/src
|
|
+LDFLAGS+= -Wl,-R${BUILDLINK_PREFIX.jpeg}/lib
|
|
+LDFLAGS+= -Wl,-R${BUILDLINK_PREFIX.zlib}/lib
|
|
+
|
|
+LDADD+= -lmfhdf -ldf -ljpeg -lz -lm
|
|
+
|
|
+NOMAN= 1
|
|
+
|
|
+test: $(PROG)
|
|
+ @ echo "==========================="
|
|
+ @ echo "netCDF C interface tests"
|
|
+ @ echo "==========================="
|
|
+ ./$(PROG)
|
|
+
|
|
+.include <bsd.prog.mk>
|