efb93b17bd
buildlink2.mk files back into the main trunk.
21 lines
709 B
Text
21 lines
709 B
Text
$NetBSD: patch-ax,v 1.2 2002/08/25 19:23:05 jlam Exp $
|
|
|
|
--- filters/fs2ikon.orig Thu Oct 24 03:26:14 1991
|
|
+++ filters/fs2ikon Sun Jul 7 16:18:17 2002
|
|
@@ -26,14 +26,14 @@
|
|
y=$2
|
|
if [ $x -ge $y ]
|
|
then
|
|
- ppmscale -width 48 $file.pgm | ppmtopgm | pgmtopbm > $file.pbm
|
|
+ pnmscale -width 48 $file.pgm | ppmtopgm | pgmtopbm > $file.pbm
|
|
set `sed -n -e 2p -e 2q $file.pbm`
|
|
yo=`expr '(' 48 - $2 ')' / 2`
|
|
pbmmake 48 48 |
|
|
pnmpaste $file.pbm 0 $yo |
|
|
pbmtoicon
|
|
else
|
|
- ppmscale -height 48 $file.pgm | ppmtopgm | pgmtopbm > $file.pbm
|
|
+ pnmscale -height 48 $file.pgm | ppmtopgm | pgmtopbm > $file.pbm
|
|
set `sed -n -e 2p -e 2q $file.pbm`
|
|
xo=`expr '(' 48 - $1 ')' / 2`
|
|
pbmmake 48 48 |
|