pkgsrc/x11/lxqt-panel/patches/patch-panel_CMakeLists.txt
pin 6b70be3cb6 x11/lxqt-panel: update to 0.16.1
0.16.1
-Fixed compilation with Qt 5.12 and Qt 5.13.

0.16.0
-Use a stylesheet for progress-bars of Sensors plugin.
-Implemented auto-hiding for Status Notifier.
-Added option to task button for moving the window to next monitor.
-Added option to place task buttons of new windows next to the existing ones
of same class when task buttons are ungrouped.
-Removed incorrect and redundant explanation of milliseconds from World Clock.
-Don't call non-const member functions on temporaries.
-Prevent possible C++11 range loop container detachment.
-Fixed the sizes and alignments of some plugins at startup.
-Added right-click menu to main menu items.
-Address deprecation warnings/errors.
-Added XF86Eject button action.
2020-12-07 12:55:28 +00:00

28 lines
957 B
Text

$NetBSD: patch-panel_CMakeLists.txt,v 1.3 2020/12/07 12:55:28 pin Exp $
Work around undefined symbol issue (which would cause the panel to fail
to run if the volume plugin was enabled), as discussed in:
https://github.com/lxqt/lxqt/issues/1075
Install fallback .conf files to a consistent location.
--- panel/CMakeLists.txt.orig 2020-11-05 16:09:19.000000000 +0000
+++ panel/CMakeLists.txt
@@ -55,6 +55,8 @@ set(LIBRARIES
lxqt
)
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Xlinker --export-dynamic")
+
file(GLOB CONFIG_FILES resources/*.conf)
############################################
@@ -104,7 +106,7 @@ target_link_libraries(${PROJECT}
)
install(TARGETS ${PROJECT} RUNTIME DESTINATION bin)
-install(FILES ${CONFIG_FILES} DESTINATION ${CMAKE_INSTALL_DATADIR}/lxqt)
+install(FILES ${CONFIG_FILES} DESTINATION share/examples/lxqt)
install(FILES ${PUB_HEADERS} DESTINATION include/lxqt)
install(FILES
man/lxqt-panel.1