7a194ddbc8
Based on patch from Tim Larson by PR#43061. CHANGES IN FLTK 1.1.10 - Widgets now remove stale entries from the default callback queue when they are deleted (STR #2302) - Fixed selection bug in Fl_Int_Input (STR #2292) - Fixed character set conversion functions (STR #2268) - Fixed image lib configure and fltk-config issues by backporting the image lib and zlib configure code from FLTK 1.3 (STR #2203) - Updated the bundled libpng to v1.2.40 (released Sep. 10, 2009) - Fixed Fl_Choice contrast with light-on-dark settings (STR #2219) - Added Xft2 font lookup table (STR #2215) - Fixed X server "lock", if a modal dialog window is opened while a menu is active (STR #1986) - Updated mirror sites in documentation (STR #2220) - Setting a default font for Xft (STR #2216) - Temporarily limited builds to 32-bit on OX S to stay compatible to Snow Leopard - Fixed Windows compile bug with "#define USE_COLORMAP 0" (STR #2241) - Fixed glibc 2.10 compiler problems (Fedora 11 and others) with scandir() and strchr() (STR #2222) - Fixed OpenGL shared context handling (STR #2135) - Fixed gray-scale images with alpha channel (STR #2105) - Fixed unexpected shortcut behavior for Win32 (STR #2199) - Added cast to Fl_Color in all Fluid code (STR #2206) - Fixed wrong identifier for special keys combined with modifier (STR #2196) - Fixed documentation for Fl_Progress (STR #2209) - Fix for multiple popups, when dragging and calling fl_alert() and friends from the callback (STR #2159) - Avoiding crashes for recursive common dialogs (this does not fix the issue at hand yet) (STR 2150) - Fluid printing used wrong colors under Windows (STR #2195) - Fixed bad system menu hadling in OS X (STR #2153) - Fixed File Input mouse pointer dragging (STR #2181) - Added Fl_Scroll::bbox() documentation (STR #1893) - Fixed static linking of image libraries (STR #1962) - Fixed callback would not be called when shortcut was used with radio and toggle buttons in default FL_RELEASE mode. - Fixed a problem with TrackMouseEvent() (Windows only) that would generate wrong FL_LEAVE events with subwindows. TrackMouseEvent is now enabled by default (it was disabled for GNU compilers). It can be disabled by defining NO_TRACK_MOUSE. Improved test/subwindow.cxx (STR #2079) - Fixed RGB colors for round box (STR #2097) - Fixed documentation (added missing COMCTRL32.LIB dependency) - Fl_Group::clip_children() is now public (STR #2017) - Fixed first modifier key event (STR #1952) - Fixed wrong default value of Fl_Spinner in Fluid (STR #1991) - Fixed Fluid textcolor output (STR #1992) - Added clarification to Fl_GL_Window mode function (STR #1945) - Fl_Group and Fl_Scroll now resize themselves before resizing their children (STR #2032) - Fixed adding an idle handler during a draw() call (STR #1950) - Improved stability of fl_read_image (STR #2021) - Fixed menu position close to screen border (STR #2057)
22 lines
943 B
Text
22 lines
943 B
Text
$NetBSD: patch-ae,v 1.8 2010/04/09 13:35:42 obache Exp $
|
|
|
|
--- fluid/Makefile.orig 2008-12-29 20:21:29.000000000 +0000
|
|
+++ fluid/Makefile
|
|
@@ -57,7 +57,7 @@ all: $(FLUID) fluid$(EXEEXT)
|
|
fluid$(EXEEXT): $(OBJECTS) $(LIBNAME) $(FLLIBNAME) \
|
|
$(IMGLIBNAME)
|
|
echo Linking $@...
|
|
- $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o $@ $(OBJECTS) $(LINKFLTKFORMS) $(LINKFLTKIMG) $(LDLIBS)
|
|
+ ${LIBTOOL} --mode=link $(CXX) $(ARCHFLAGS) $(LDFLAGS) -o $@ $(OBJECTS:.o=.lo) $(LINKFLTKFORMS) $(LINKFLTKIMG) $(LDLIBS)
|
|
$(OSX_ONLY) $(INSTALL_BIN) fluid fluid.app/Contents/MacOS
|
|
$(POSTBUILD) $@ ../FL/mac.r
|
|
|
|
@@ -81,7 +81,7 @@ include makedepend
|
|
install: all
|
|
echo "Installing FLUID in $(DESTDIR)$(bindir)..."
|
|
-$(INSTALL_DIR) $(DESTDIR)$(bindir)
|
|
- $(INSTALL_BIN) $(FLUID) $(DESTDIR)$(bindir)/fluid$(EXEEXT)
|
|
+ ${LIBTOOL} --mode=install $(INSTALL_BIN) $(FLUID) $(DESTDIR)$(bindir)/fluid$(EXEEXT)
|
|
|
|
install-linux:
|
|
-$(INSTALL_DIR) $(DESTDIR)/usr/share/applications
|