7b899ce8ac
Changes: 1.2.10: * Gtk::Editable: removed default arg values from implementation, as suggested by Otmar Struwe. This allows it to build with gcc 3.1 1.2.9: * Gtk::SArray_Helpers::Traits<T>: Added specializations for 'const T*', 'T *const', 'const T *const' and 'const T[N]', so that the inofficial RedHat GCC 2.96 chooses the correct one. Release: Gtk-- 1.2.8 * CList_Helpers::Row::Row() implemented, not just declared. (Murray Cumming) * FontSelection::get_font_name(): Prevent crash when GTK+ returns 0. (Joe Yandle) * Fixed memory leak in Gtk::Editable::get_chars() (Gergo) * Gtk::Widget::get_toplevel is more cautious if the return value is not a Gtk::Window* (Gergo) Release: Gtk-- 1.2.7 * Minor gtkmmproc install fix. (Grumegargler) * Lots of reference documentation text added, based on the GTK+ reference documentation. (Jason M'Sadoques) * gtkmm-config does not give -I/usr/include, which should be implicit if necessary, and which overrides the implicit gcc replacement system headers if used. Apparently this is useful for gcc 3.0, and is what gtk+ does.(Daniel Elstner) Release: Gtk-- 1.2.6 Skipped. Release: Gtk-- 1.2.5 * Fixes for code generator. * Fixes for RedHat 7.0 configure bug. * Numerous patches to clean up code and improve appearance. * Added SpinButton::update() (Augustin Ferrin Pozuelo) * Menushell namespace fixes (jaycox) * Fixes for gtk--.m4 (srittau) * Major CTree fixes * CTree::selection() fixed. (Murray Cumming) * Added CTree::{Row,Column}::moveto() * Fix for CTree::RowList::end() (Daniel Elstner) * Documentation fixes (Falk Hueffner) * TreeItem patch (Joe Yandle) Converted to buildlink2 by me.
13 lines
579 B
Text
13 lines
579 B
Text
$NetBSD: patch-ah,v 1.3 2002/09/11 21:53:50 wiz Exp $
|
|
|
|
--- src/gtk--/Makefile.in.orig Tue Apr 9 14:34:18 2002
|
|
+++ src/gtk--/Makefile.in Tue May 28 14:00:01 2002
|
|
@@ -142,7 +142,7 @@
|
|
|
|
# This builds the library
|
|
libgtkmm_la_SOURCES = $(gtkmmc) gtk--.cc proxy.cc base.cc marshal.cc
|
|
-libgtkmm_la_LDFLAGS = -version-info $(LIBGTKMM_SO_VERSION) -release $(GTKMM_RELEASE) -no-undefined
|
|
+libgtkmm_la_LDFLAGS = -version-info $(LIBGTKMM_SO_VERSION) -no-undefined
|
|
libgtkmm_la_INCLUDES = $(GTK_CFLAGS)
|
|
libgtkmm_la_LIBADD = $(GTK_LIBS) $(gtkmmla)
|
|
#libgtkmm_la_DEPENDENCIES = $(gtkmmla)
|