4e8cef0fb0
2004/12/2 Gauche 0.8.3: Bug fix release It turned out that 0.8.2's source-code encoding detection feature had a bug; if you're using Windows-style (CRLF) line-separator, the coding-aware port repeats one character at the beginning of the second line. It doesn't do any harm if first few lines of your code are comments, but it's annoying when you stumbled on it, so I decided to release a fixed version. This release also includes a couple of improvements: The coding-aware ports recognizes Emacs-style coding name (e.g. euc-jp-unix) and just ignores the Emacs-specific suffix (e.g. -unix). And external representations of f32vector and f64vector are now accurate. 2004/11/29 Gauche 0.8.2: Major revision of infrastructure. * New features - A condition (exception) system a la srfi-35 and (part of) srfi-36 is supported. Used with guard (srfi-34), now it is possible to handle exceptions in more comprehensive way. See the "Exception" section of the manual, which has been rewritten accordingly. - Source-code encoding detection. Now Gauche recognizes a special comment like "coding: utf-8" near the beginning of the source file, and use appropriate conversion to load the source file. See "Multibyte Script" section of the manual for the details. This feature alone can be used independently from loading programs, via coding-aware ports, so the programs that processes Scheme scripts can also recognize the special comments. - Virtual ports are supported. Virtual ports are the ports whose behavior can be customized in Scheme. See the description of gauche.vport module in the manual for the details. * Improvements - Updated GC to Boehm GC 6.3. It fixes some GC-related problems on 64bit architectures. - gauche.fcntl: F_GETOWN and F_SETOWN are supported, if the system provides them. - gauche.termios: c_cc field of struct termios is now accessible from Scheme. (Thanks to Kogule Ryo). - gauche.uvector: Added string->s8vector! and string->s8vector!. TAGvector-copy!'s API is changed so that it matches with srfi-13's string-copy! and srfi-43's vector-copy!. - Port implementation is cleaned up. Now line count is available not only for file ports but any ports (as far as it's doing character I /O). byte-ready? is added for binary I/O polling. - text.csv: quote character is customizable. * Bug fixes - INCOMPATIBLE CHANGE: The previous version's rfc.mime's API was broken. It couldn't handle MIME part whose message was non-encoded binary. Now MIME part stream parser is re-implemented using virtual ports, and the reader argument passed to the MIME part handler is dropped. www.cgi is also affected if you're using customized handler for file uploads. See the reference manual for the new API. - SONAME of the library is now set, if the platform supports it. - gauche.array: Some functions were not exported, although they were mentioned in the manual. - gauche.charconv: Fixed a bug in converting 2nd plane of JIS. - gauche.regexp: regexp-replace-all looped infinitely for some patterns. Now it raises an error. - dbm.fsdbm: It couldn't store binary data. - rfc.822: rfc822-parse-date returned wrong month number (off by one). - util.match: Fixed a bug in quasipattern. The description of quasipatterns in the reference manual is also revised to explain it better. - srfi-19: date->julian-day didn't recognize tz-offset. - Some bugs in numeric code are fixed. - let-args had a bug in parameter handling of 'else' clause. - directory-list: when :filter-add-path? is true, there was a bug that "." and ".." were included in the results even :children? argument was true. - There was a bug that causes an infinite loop during class redefinition. - let-keywords*: fixed a bug that corrupts expansion when used in r5rs macro. * C API Change - Class initialization API is overhauled. Scm_InitBuiltinClass is obsoleted; use Scm_InitStaticClass instead. - Port structure is changed quite a bit. - Functions to convert Scheme integers to C integers are revised, to handle out-of-range error in more flexible way. - API of Scm_Load, Scm_LoadFromPort and related functions are changed to support more flags.
52 lines
1.9 KiB
Text
52 lines
1.9 KiB
Text
$NetBSD: patch-ac,v 1.4 2005/01/16 08:57:55 kei Exp $
|
|
|
|
--- src/Makefile.in.orig 2004-11-22 07:36:28.000000000 +0900
|
|
+++ src/Makefile.in 2005-01-16 17:42:25.000000000 +0900
|
|
@@ -46,7 +46,7 @@
|
|
# These are set by configure
|
|
DEFS = @DEFS@
|
|
OPTFLAGS = @OPTFLAGS@
|
|
-INCLUDES = -I$(srcdir) -I$(srcdir)/../gc/include @LOCAL_INC@
|
|
+INCLUDES = -I$(srcdir) -I@prefix@/include/gc @LOCAL_INC@
|
|
RANLIB = @RANLIB@
|
|
OBJEXT = @OBJEXT@
|
|
EXEEXT = @EXEEXT@
|
|
@@ -81,10 +81,7 @@
|
|
SITE_ARCH_DIR = $(GAUCHE_ARCH_DIR)/site/@GAUCHE_VERSION@/@host@
|
|
ARCH = @host@
|
|
|
|
-INSTALL_HEADERS = gauche.h \
|
|
- ../gc/include/gc.h \
|
|
- ../gc/include/gc_config_macros.h \
|
|
- ../gc/include/gc_pthread_redirects.h
|
|
+INSTALL_HEADERS = gauche.h
|
|
INSTALL_SUBHEADERS = gauche/config.h gauche/vm.h gauche/vminsn.h \
|
|
gauche/char_euc_jp.h gauche/char_utf_8.h \
|
|
gauche/char_sjis.h gauche/char_none.h \
|
|
@@ -108,7 +105,7 @@
|
|
|
|
# build -----------------------------------------------
|
|
|
|
-GCLIB = ../gc/libgc.la
|
|
+GCLIB = @prefix@/lib/libgc.la
|
|
|
|
gosh_SOURCES = main.c
|
|
gosh_OBJECTS = main.$(OBJEXT)
|
|
@@ -140,7 +137,7 @@
|
|
$(LINK) $(gosh_LDFLAGS) -o gosh$(EXEEXT) $(gosh_OBJECTS) $(gosh_LDADD) $(LIBS)
|
|
|
|
relink :
|
|
- $(RELINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) ../gc/*.lo $(LIBS)
|
|
+ $(RELINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) @prefix@/lib/libgc.$(SOEXT) $(LIBS)
|
|
$(RELINK) $(gosh_LDFLAGS) -o gosh$(EXEEXT) $(gosh_OBJECTS) $(gosh_LDADD) $(LIBS)
|
|
|
|
$(OBJECTS) : $(HEADERS)
|
|
@@ -164,7 +161,7 @@
|
|
load.$(OBJEXT) : dl_dlopen.c dl_dummy.c dl_win.c dl_darwin.c
|
|
|
|
libgauche.$(SOEXT) : $(libgauche_OBJECTS) $(GCLIB)
|
|
- $(LINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) ../gc/*.lo $(LIBS)
|
|
+ $(LINK) $(libgauche_LDFLAGS) libgauche.$(SOEXT) $(libgauche_OBJECTS) @prefix@/lib/libgc.$(SOEXT) $(LIBS)
|
|
$(POSTBUILD)
|
|
|
|
gauche/arch.h :
|