pkgsrc/comms/jpilot-syncmal/patches/patch-ab
wiz 559a1407a0 Update to 0.71, makes it compile again with latest jpilot.
Changes since 0.60:
0.71 - 4/27/2002
- Support for pilot-link 0.10
- syncmal.c now includes errno.h
  -- Thanks to Renaud Pacalet and Ludovic Rousseau, both of whom pointed out
these errors and how to fix them
- Added GPL exception text to the boilerplate in libplugin.h and prefs.h,
with Judd's permission

0.70 - 4/7/2002
- Distribution now includes necessary J-Pilot headers (libplugin.h and
prefs.h) and malsync-2.0.7 source.
- Updated README for vastly simplified build instructions
- Added jpilot-syncmal.spec

0.62.2 - 2/7/2002
- Updated prefs code to use the new API (J-Pilot 0.99.2 and later)

0.62 - 5/9/2001
- Fixed a typo in skip_sync which would cause it to fail if any interval
other than always was selected.  Thanks to Chris Bagwell for identifying
this bug.

0.61 - 3/3/2001  Very minor changes
- Fix an error in configure.in which caused the build to fail on Solaris
- Added some comments to syncmal.c
2003-01-13 13:21:07 +00:00

21 lines
774 B
Text

$NetBSD: patch-ab,v 1.1 2003/01/13 13:21:09 wiz Exp $
--- malsync/mal/common/AGNet.h.orig Fri Jan 5 17:50:07 2001
+++ malsync/mal/common/AGNet.h
@@ -54,6 +54,7 @@
# else /* defined(macintosh) */
# include <netdb.h>
# include <sys/types.h>
+# include <sys/param.h>
# include <sys/socket.h>
# include <unistd.h>
# include <netinet/in.h>
@@ -61,7 +62,7 @@
# include <sys/filio.h>
# include <arpa/inet.h>
# else
-# if defined(__FreeBSD__) || defined(_HPUX_SOURCE)
+# if (defined(BSD) && BSD >= 199306) || defined(_HPUX_SOURCE)
# include <sys/ioctl.h>
# include <arpa/inet.h>
# else