pkgsrc/lang/sr/patches/patch-at
is b5c36df76f This is the SR, a language for concurrent programming from the
University of Arizona, version 2.3.2.

SR is described in "The SR Programming Language: Concurrency in Practice"
by Gregory R. Andrews and Ronald A. Olsson (Benjamin/Cummings, 1993, ISBN
0-8053-0088-0).
2005-02-25 15:54:58 +00:00

45 lines
1.2 KiB
Text

$NetBSD: patch-at,v 1.1.1.1 2005/02/25 15:54:59 is Exp $
--- csw/Makefile.orig 1999-07-30 07:01:50.000000000 +0200
+++ csw/Makefile
@@ -1,6 +1,6 @@
## Makefile for the SR context switch routines.
-CFLAGS = -g
+CFLAGS = -O3
SHELL = /bin/sh
SRC = alpha.s ap3000.s bobcat.s encore.s i386.s m68k.s m88k.s mips.s \
@@ -16,6 +16,8 @@ OKAY: cstest
cmp cstest.out cstest.stdout
echo "`date`: cstest passed" >OKAY
+_context_u.o: ; ar xv /usr/lib/libpthread.a _context_u.o
+pthread_md.o: ; ar xv /usr/lib/libpthread.a pthread_md.o
# cstest is the test program
@@ -27,19 +29,15 @@ cstest: cstest.o asm.o
# csloop is a timing program, built only on request
csloop: csloop.o asm.o
- . ../paths.sh; $(CC) -O -o csloop csloop.o asm.o $$LIBR $$LIBC
+ . ../paths.sh; $(CC) -g -o csloop csloop.o asm.o $$LIBR $$LIBC
csloop.o: csloop.c
$(CC) -O -c csloop.c
-# asm.o holds the actual context switch code
-
-asm.o: asm.c ../arch.h $(SRC)
- $(CC) $(CFLAGS) -E asm.c | \
- sed -e '/^ *$$/d' -e '/^#/'d -e 's/ :/:/' >asm.s
- as -o asm.o asm.s
-
+asm.o: netbsd.c pthread_md.o _context_u.o
+ $(CC) $(CFLAGS) -c netbsd.c
+ $(LD) -r -o asm.o netbsd.o pthread_md.o _context_u.o
# miscellaneous utility targets