3e1d59d803
Some major performance improvements Numerous minor bug fixes and enhancements Added a do-test target to the pkgsrc Makefile
24 lines
773 B
Text
24 lines
773 B
Text
$NetBSD: patch-src_utils_htslib_Makefile,v 1.2 2021/02/08 01:49:25 bacon Exp $
|
|
|
|
# Respect pkgsrc env
|
|
|
|
--- src/utils/htslib/Makefile.orig 2021-01-23 19:33:26.000000000 +0000
|
|
+++ src/utils/htslib/Makefile
|
|
@@ -22,7 +22,7 @@
|
|
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
|
|
# DEALINGS IN THE SOFTWARE.
|
|
|
|
-CC = gcc
|
|
+CC ?= gcc
|
|
AR = ar
|
|
RANLIB = ranlib
|
|
|
|
@@ -33,7 +33,7 @@ CPPFLAGS =
|
|
# TODO: probably update cram code to make it compile cleanly with -Wc++-compat
|
|
# For testing strict C99 support add -std=c99 -D_XOPEN_SOURCE=600
|
|
#CFLAGS = -g -Wall -O2 -pedantic -std=c99 -D_XOPEN_SOURCE=600 -D__FUNCTION__=__func__
|
|
-CFLAGS = -g -Wall -O2
|
|
+CFLAGS ?= -g -Wall -O2
|
|
EXTRA_CFLAGS_PIC = -fpic
|
|
LDFLAGS =
|
|
LIBS = $(htslib_default_libs)
|