4c72de9106
pangomm (used to be part of gtkmm) is the official C++ interface for the popular GUI library GTK+. Highlights include typesafe callbacks, widgets extensible via inheritance and a comprehensive set of widget classes that can be freely combined to quickly create complex user interfaces. This package follows the 2.48 API. Changes compared to pangomm: 2.48.1 (stable): * GlyphItem: Fix a memory leak in split() (Kjell Ahlstedt) * Layout: Speed up get_log_attrs() (Kjell Ahlstedt) Build: * Meson build: Use relative paths to untracked/ (Kjell Ahlstedt) Merge request gtkmm!61 (Mingli Yu) * pangommconfig.h.*: Don't dllimport on MinGW (Chun-wei Fan) Issue gtkmm#90 (Lukas K.) * Meson build: Make it possible to use pangomm as a subproject (Kjell Ahlstedt) * Meson build: No implicit_include_directories (Kjell Ahlstedt) 2.48.0 (stable): This is the first stable release in the pangomm-2.48 ABI series. It is parallel-installable with the pangomm-1.4 ABI. The tarball for 2.48.0 has been created with 'meson dist'. If you build with Autotools from the tarball, please read the relevant part of the README file. * FontFamily, FontMap: Implement the Gio::ListModel interface CairoFontMap: Add get_default() (Andreas Persson) Merge request !20 * Attribute: Add Overline and ShowFlags enums and some create*() methods Renderer: Add vfuncs (Kjell Ahlstedt) Issue #9 (misos1) * Font, FontFace, FontFamily, FontMetrics: Add new methods (Kjell Ahlstedt) * LayoutRun: Rename to GlyphItem (Kjell Ahlstedt) * LayoutIter: Fix get_run() and get_line() (Kjell Ahlstedt) * GlyphString, Item: Wrap pango_shape_with_flags() (Kjell Ahlstedt) Issue #9 (Tavmjong Bah) * Layout: Add set/get_line_spacing() (Kjell Ahlstedt) Issue #9 (misos1) Build: * Depend on giomm (not just glibmm) (Andreas Persson) Merge request !20 * Use __declspec(dllexport) when building with Visual Studio (Chun-wei Fan) Merge request !15, !16 * Meson build: Avoid some recompilations (Kjell Ahlstedt) * Meson build: Better error message if trying to build with maintainer-mode=false when true is necessary (Kjell Ahlstedt) Issue #6 (Rasmus Thomsen) * Meson build: Set default value of the 'warnings' option to 'min' (Kjell Ahlstedt) * Improve NMake support (Chun-wei Fan) * Improve Visual Studio support (Chun-wei Fan) Merge request !15, !19 * docs/reference/: Update for Doxygen >= 1.8.16 (Kjell Ahlstedt) * Meson build: Fix versioning on macOS (Kjell Ahlstedt) Pull request libsigcplusplus#65 (Tom Schoonjans) * Change the ABI to pangomm-2.48 (Kjell Ahlstedt)
15 lines
487 B
Text
15 lines
487 B
Text
$NetBSD: patch-meson.build,v 1.1 2021/05/31 22:29:20 wiz Exp $
|
|
|
|
Fix finding Python.
|
|
|
|
--- meson.build.orig 2021-04-08 16:35:21.531396769 +0000
|
|
+++ meson.build
|
|
@@ -43,7 +43,7 @@ project_build_root = meson.current_build
|
|
|
|
cpp_compiler = meson.get_compiler('cpp')
|
|
is_msvc = cpp_compiler.get_id() == 'msvc'
|
|
-python3 = import('python').find_installation('python3')
|
|
+python3 = import('python').find_installation()
|
|
|
|
python_version = python3.language_version()
|
|
python_version_req = '>= 3.5'
|