50 lines
1.4 KiB
Text
50 lines
1.4 KiB
Text
$NetBSD: patch-ab,v 1.2 2002/04/16 13:55:30 wiz Exp $
|
|
|
|
--- rx/Makefile.in.orig Fri Nov 22 13:47:49 1996
|
|
+++ rx/Makefile.in
|
|
@@ -59,24 +59,23 @@
|
|
$(CC) $(ALL_CFLAGS) -DSCM_MAGIC_SNARFER -E $< | grep "^%%%" | sed -e "s/^%%%//" > $@ ; \
|
|
|
|
.c.o:
|
|
- $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $<
|
|
+ $(LIBTOOL) $(CC) -c $(ALL_CFLAGS) $(DEFS) -I$(srcdir) $<
|
|
|
|
-all: librx.a
|
|
+all: librx.la
|
|
|
|
install: all
|
|
test -d $(libdir) || mkdir $(libdir)
|
|
test -d $(includedir) || mkdir $(includedir)
|
|
- $(INSTALL) librx.a $(libdir)/librx.a
|
|
- $(RANLIB) $(libdir)/librx.a
|
|
- $(INSTALL) $(srcdir)/inst-rxposix.h $(includedir)/rxposix.h
|
|
+ $(LIBTOOL) $(INSTALL) librx.la $(libdir)
|
|
+ $(BSD_INSTALL_DATA) $(srcdir)/inst-rxposix.h $(includedir)/rxposix.h
|
|
|
|
|
|
uninstall:
|
|
- -rm -f $(libdir)/librx.a
|
|
+ -$(LIBTOOL) rm -f $(libdir)/librx.la
|
|
-rm -f $(includedir)/rxposix.h
|
|
|
|
clean:
|
|
- -rm -f $(libobjs) librx.a $(opt_objs)
|
|
+ -$(LIBTOOL) rm -f $(libobjs) librx.a $(opt_objs)
|
|
|
|
distclean: clean
|
|
-rm Makefile config.status config.log rgx.x
|
|
@@ -111,10 +110,10 @@
|
|
rm -rf `cat .fname` .fname
|
|
|
|
|
|
-librx.a: $(libobjs) $(opt_objs)
|
|
- rm -f librx.a
|
|
- $(AR) $(AR_FLAGS) librx.a $(libobjs) $(opt_objs)
|
|
- $(RANLIB) librx.a
|
|
+librx.la: $(libobjs) $(opt_objs)
|
|
+ $(LIBTOOL) rm -f librx.la
|
|
+ $(LIBTOOL) $(CC) -o $@ $(libobjs:.o=.lo) $(opt_objs:.o=.lo) \
|
|
+ -rpath $(libdir) -version-info $(RX_MAJOR):$(RX_MINOR)
|
|
|
|
|
|
depends:
|