be55e1e30f
- Complete redesign of the icy world and forest world (Thank you, RustyBox and Serano) - Complete revamp of our rendering engine, the game should be much faster than it was previously - We now support OpenGL 3.3 Core as well as OpenGL ES 2.0, thus allowing SuperTux to be run on the Raspberry Pi, and potentially WebGL. - Support for right-to-left languages through vector fonts. This will also fix a few non-ASCII characters, which often caused problems before in translations - A lot of other under-the-hood changes and bugfixes A few graphics have been updated, and effects have been added: - The save bell was reworked (Thanks to Raghavendra “raghukamath” Kamath!) - Improved big Tux graphics and animations (Thanks to Alzter) - Various effects and shaders (Thanks to Grumbel)
14 lines
431 B
Text
14 lines
431 B
Text
$NetBSD: patch-external_squirrel_CMakeLists.txt,v 1.1 2019/07/01 15:13:20 nia Exp $
|
|
|
|
Disable building the dynamic library.
|
|
|
|
--- external/squirrel/CMakeLists.txt.orig 2018-12-23 19:11:41.000000000 +0000
|
|
+++ external/squirrel/CMakeLists.txt
|
|
@@ -6,6 +6,7 @@ endif()
|
|
|
|
set(CMAKE_INSTALL_PREFIX "${CMAKE_SOURCE_DIR}" CACHE PATH "")
|
|
set(CMAKE_BUILD_TYPE "Release" CACHE STRING "")
|
|
+set(DISABLE_DYNAMIC ON)
|
|
|
|
project(squirrel C CXX)
|
|
|