848d99f1a8
fixed a coredump in torrent (introduced in 4.1.2). Version 4.1.2 - 2010-12-31 new command ln [-s], supported by FTP (SITE [SYM]LINK), FISH, SFTP, and locally via file: schema. create remote symlinks in mirror -R if supported by server. detect and remove duplicate peers in torrent. Version 4.1.0 - 2010-11-22 send path components to ftp server separately, unless TVFS is in FEAT reply. save pget status at the very beginning of pget execution. allow mirror pget continuation (mirror -c --use-pget). allow multiple torrent startup at once (e.g. torrent *.torrent). pre-allocate disk space in torrent, if posix_fallocate(3) is supported. new command prefix `local'. It makes the following command use local session instead of remote. added torrent multi-tracker support. fixed convert-mozilla-cookies cookie duplication. Version 4.0.10 - 2010-09-01 use cached file set, don't parse file listing again. updated convert-netscape-cookies. fixed a problem with zeroed errno in http. fixed coredump on mirror --log=file when the file cannot be opened. translations updated (de, ru).
39 lines
1.5 KiB
Text
39 lines
1.5 KiB
Text
$NetBSD: patch-aa,v 1.16 2011/03/10 23:38:42 pettai Exp $
|
|
|
|
Do not install by default Perl scripts; they are installed via
|
|
${INSTALL_SCRIPT} if the user set the "perl" option.
|
|
|
|
Do not remove the *.la files.
|
|
|
|
$NetBSD: patch-aa,v 1.16 2011/03/10 23:38:42 pettai Exp $
|
|
|
|
--- src/Makefile.in.orig 2011-01-17 08:29:59.000000000 +0000
|
|
+++ src/Makefile.in
|
|
@@ -1178,7 +1178,7 @@ top_builddir = @top_builddir@
|
|
top_srcdir = @top_srcdir@
|
|
pkgverlibdir = $(pkglibdir)/$(VERSION)
|
|
bin_SCRIPTS = lftpget
|
|
-pkgdata_SCRIPTS = import-ncftp import-netscape verify-file convert-mozilla-cookies
|
|
+pkgdata_SCRIPTS = import-ncftp import-netscape
|
|
noinst_SCRIPTS = ftpget
|
|
EXTRA_DIST = $(pkgdata_SCRIPTS) $(bin_SCRIPTS) $(noinst_SCRIPTS)
|
|
lftp_SOURCES = lftp.cc complete.h complete.cc lftp_rl.c lftp_rl.h
|
|
@@ -1776,7 +1776,7 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRA
|
|
install-binPROGRAMS: install-libLTLIBRARIES
|
|
|
|
installdirs:
|
|
- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgverlibdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"; do \
|
|
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgdatadir)"; do \
|
|
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
|
done
|
|
install: install-am
|
|
@@ -1906,6 +1906,9 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
|
|
# libtool does not strip modules, do it here.
|
|
install-data-hook:
|
|
+ :
|
|
+
|
|
+install-data-hook-disabled:
|
|
@WITH_MODULES_TRUE@ rm -f $(DESTDIR)$(pkgverlibdir)/*.la; \
|
|
@WITH_MODULES_TRUE@ case " $(LDFLAGS) " in *" -s "*) \
|
|
@WITH_MODULES_TRUE@ $(STRIP) $(DESTDIR)$(pkgverlibdir)/*.so;; \
|