e7a91fc2fa
This large commit accomplishes the following: 1) Switch USE_LANGUAGES=ada to require lang/gcc5-aux (gcc 5.4) instead of lang/gcc-aux (gcc 4.9.2) on gcc.mk 2) Bump affected ports and fix paths as necessary 3) Upgrade devel/gprbuild to the latest release - No longer requires lang/gnat_util - gprslave requires gcc6-aux, so it was disabled for now 4) Fix lang/gnat_util but set PKG_SKIP_REASON - It has no further purpose in the pkgsrc tree - It has no practical purpose outside of the pkgsrc tree - Indicate intent to remove from tree in Jan. 2017 5) Set devel/GPS as failed with PKG_FAIL_REASON - This version of GPS is several years old and at the time they were strongly tied to compiler. - Latest release of GPS require gcc6-aux (not available) and several new and complex dependencies - maintainer (me) has no interest to continue supporting it - Leaving GPS in place until Jan 2017 to give another person chance to upgrade and take over support - Latest version in FreeBSD Ports Collection as a reference point
24 lines
796 B
XML
24 lines
796 B
XML
$NetBSD: patch-share_gprconfig_gnat.xml,v 1.3 2016/11/25 20:36:49 marino Exp $
|
|
|
|
Tailor standard gprbuild to recognize gcc-aux / Ada framework
|
|
|
|
--- share/gprconfig/gnat.xml.orig 2014-10-13 22:03:37 UTC
|
|
+++ share/gprconfig/gnat.xml
|
|
@@ -63,7 +63,7 @@
|
|
</config>
|
|
</configuration>
|
|
|
|
- <!-- GNAT -->
|
|
+ <!-- GNAT (tailored to lang/gcc5-aux) -->
|
|
<configuration>
|
|
&filter_gnat;
|
|
<config>
|
|
@@ -75,7 +75,7 @@
|
|
end Naming;
|
|
|
|
package Compiler is
|
|
- for Driver ("Ada") use "${PATH(ada)}${PREFIX(ada)}gcc";
|
|
+ for Driver ("Ada") use "${PATH(ada)}${PREFIX(ada)}ada";
|
|
for Language_Kind ("Ada") use "unit_based";
|
|
for Dependency_Kind ("Ada") use "ALI_File";
|
|
for Leading_Required_Switches ("Ada") use
|