This moves this pkg to the new stable gnome branch, too much to list here. pkgsrc notes: -look for X server at ${X11BASE}/bin/X too, to make it work with modular-xorg out of the box -improved paths to shutdown etc. for netbsd -Use dbus-launch to start gnome-session on netbsd, to avoid the autostart which fails for me. At least Debian does so too.
49 lines
1.9 KiB
Text
49 lines
1.9 KiB
Text
$NetBSD: patch-ae,v 1.13 2007/04/11 20:40:08 drochner Exp $
|
|
|
|
--- config/Makefile.in.orig 2007-03-11 22:48:34.000000000 +0100
|
|
+++ config/Makefile.in
|
|
@@ -582,10 +582,6 @@ install-data-hook: gdm.conf gdm.conf-cus
|
|
$(mkinstalldirs) $(DESTDIR)$(confdir); \
|
|
chmod 755 $(DESTDIR)$(confdir); \
|
|
fi
|
|
- if test '!' -d $(DESTDIR)$(dmconfdir); then \
|
|
- $(mkinstalldirs) $(DESTDIR)$(dmconfdir); \
|
|
- chmod 755 $(DESTDIR)$(dmconfdir); \
|
|
- fi
|
|
if test '!' -d `dirname $(DESTDIR)$(GDM_DEFAULTS_CONF)`; then \
|
|
$(mkinstalldirs) `dirname $(DESTDIR)$(GDM_DEFAULTS_CONF)`; \
|
|
chmod 755 `dirname $(DESTDIR)$(GDM_DEFAULTS_CONF)`; \
|
|
@@ -614,10 +610,7 @@ install-data-hook: gdm.conf gdm.conf-cus
|
|
$(INSTALL_SCRIPT) $(srcdir)/XKeepsCrashing $(DESTDIR)$(confdir)/XKeepsCrashing
|
|
$(INSTALL_SCRIPT) Xsession $(DESTDIR)$(confdir)/Xsession
|
|
|
|
- -if test -f $(DESTDIR)$(gdmlocaledir)/locale.alias; then \
|
|
- cp -f $(DESTDIR)$(gdmlocaledir)/locale.alias $(DESTDIR)$(gdmlocaledir)/locale.alias.orig; \
|
|
- fi
|
|
- $(INSTALL_DATA) $(srcdir)/locale.alias $(DESTDIR)$(gdmlocaledir)/locale.alias
|
|
+ $(INSTALL_DATA) $(srcdir)/locale.alias $(DESTDIR)$(confdir)/locale.alias
|
|
|
|
if test '!' -d $(DESTDIR)$(bisessdir); then \
|
|
$(mkinstalldirs) $(DESTDIR)$(bisessdir); \
|
|
@@ -695,20 +688,8 @@ install-data-hook: gdm.conf gdm.conf-cus
|
|
chmod 755 $(DESTDIR)$(gnomercdir); \
|
|
fi
|
|
|
|
- if test '!' -d $(DESTDIR)$(logdir); then \
|
|
- $(mkinstalldirs) $(DESTDIR)$(logdir); \
|
|
- chmod 755 $(DESTDIR)$(logdir); \
|
|
- chown root:root $(DESTDIR)$(logdir) || : ; \
|
|
- fi
|
|
-
|
|
- if test '!' -d $(DESTDIR)$(authdir); then \
|
|
- $(mkinstalldirs) $(DESTDIR)$(authdir); \
|
|
- chmod 1770 $(DESTDIR)$(authdir); \
|
|
- chown root:gdm $(DESTDIR)$(authdir) || : ; \
|
|
- fi
|
|
-
|
|
system=`uname`; \
|
|
- if test -f /usr/include/security/pam_appl.h; then \
|
|
+ if false; then \
|
|
if test '!' -d $(DESTDIR)$(PAM_PREFIX)/pam.d; then \
|
|
$(mkinstalldirs) $(DESTDIR)$(PAM_PREFIX)/pam.d; \
|
|
chmod 755 $(DESTDIR)$(PAM_PREFIX)/pam.d; \
|