pkgsrc/x11/fltk2/patches/patch-ab
2013-04-30 22:31:52 +00:00

45 lines
1.4 KiB
Text

$NetBSD: patch-ab,v 1.2 2013/04/30 22:31:52 joerg Exp $
--- configure.in.orig 2007-07-24 11:25:53.000000000 +0000
+++ configure.in
@@ -685,7 +685,7 @@ case $uname in
dnl Check for the Xshm extension unless disabled...
AC_ARG_ENABLE(xshm, [ --enable-xshm turn on MIT-SHM support (default=no)])
- if test x$enable_xshm == xyes; then
+ if test x$enable_xshm = xyes; then
AC_CHECK_HEADER(X11/extensions/XShm.h, AC_DEFINE(USE_XSHM),,
[#include <X11/Xlib.h>])
fi
@@ -812,31 +812,6 @@ if test -n "$GCC"; then
# Previous versions of GCC do not have the reliance on the stdc++
# or g++ libraries, so the extra supc++ library is not needed.
- AC_MSG_CHECKING(if libsupc++ is required)
-
- SUPC="`$CXX -print-file-name=libsupc++.a 2>/dev/null`"
- case "$SUPC" in
- libsupc++.a*)
- # Library not found, so this is and older GCC...
- AC_MSG_RESULT(no)
- ;;
- *)
- # This is gcc 3.x, and it knows of libsupc++, so we need it
- case "$uname" in
- # do not add for Darwin as it is already linked with it
- Darwin*)
- ;;
- *)
- LIBS="$LIBS -lsupc++"
- AC_MSG_RESULT(yes)
- ;;
- esac
- esac
-
- if test x$uname != xDarwin; then
- CXX="$CC"
- fi
-
AC_ARG_ENABLE(exceptions, [ --enable-exceptions turn on GCC exceptions (default=yes)])
if test x$enable_exceptions != xno; then
AC_DEFINE(HAVE_EXCEPTIONS)