pkgsrc/x11/modular-xorg-server
maya 0709a8db85 modular-xorg-*: provide patch (making this package equivalent to
xorg-server 1.20.9, couldn't find a tarball).

X.Org security advisory: July 31, 2020

X Server Pixel Data Uninitialized Memory Information Disclosure
===============================================================

CVE-2020-14347

Allocation for pixmap data in AllocatePixmap() does not initialize the
memory in xserver, it leads to leak uninitialize heap memory to
clients. When the X server runs with elevated privileges.

This flaw can lead to ASLR bypass, which when combined with other
flaws (known/unknown) could lead to lead to privilege elevation in the
client.

Patch
=====

A patch for this issue has been commited to the xorg server git
repository.  xorg-server 1.20.9 will be released shortly and will
include this patch.

https://gitlab.freedesktop.org/xorg/xserver.git

diff --git a/dix/pixmap.c b/dix/pixmap.c
index 1186d7dbb..5a0146bbb 100644
--- a/dix/pixmap.c
+++ b/dix/pixmap.c
@@ -116,7 +116,7 @@ AllocatePixmap(ScreenPtr pScreen, int pixDataSize)
     if (pScreen->totalPixmapSize > ((size_t) - 1) - pixDataSize)
         return NullPixmap;

-    pPixmap = malloc(pScreen->totalPixmapSize + pixDataSize);
+    pPixmap = calloc(1, pScreen->totalPixmapSize + pixDataSize);
     if (!pPixmap)
         return NullPixmap;

Thanks
======

This vulnerability was discovered by Jan-Niklas Sohn working with
Trend Micro Zero Day Initiative.
2020-07-31 16:50:57 +00:00
..
patches modular-xorg-*: provide patch (making this package equivalent to 2020-07-31 16:50:57 +00:00
buildlink3.mk
DESCR
distinfo modular-xorg-*: provide patch (making this package equivalent to 2020-07-31 16:50:57 +00:00
Makefile modular-xorg-*: provide patch (making this package equivalent to 2020-07-31 16:50:57 +00:00
Makefile.common modular-xorg-server: update to 1.20.8 2020-03-30 11:49:39 +00:00
MESSAGE
options.mk modular-xorg-server: update to 1.20.7. 2020-01-15 14:24:03 +00:00
PLIST Add x11/modular-xorg-xwayland. 2019-08-22 19:52:29 +00:00