pkgsrc/security/openssh/patches/patch-ab
wiz 23810a3f2a Update to 3.8.1p1:
Minor bugfixes.
2004-05-10 18:12:23 +00:00

63 lines
1.7 KiB
Text

$NetBSD: patch-ab,v 1.17 2004/05/10 18:12:24 wiz Exp $
--- configure.ac.orig 2004-04-17 05:03:07.000000000 +0200
+++ configure.ac
@@ -456,6 +456,9 @@ mips-sony-bsd|mips-sony-newsos4)
;;
esac
+# pkgsrc handles any rpath settings this package needs
+need_dash_r=
+
# Allow user to specify flags
AC_ARG_WITH(cflags,
[ --with-cflags Specify additional flags to pass to compiler],
@@ -2824,9 +2827,17 @@ AC_TRY_COMPILE([
)
if test -z "$conf_utmpx_location"; then
if test x"$system_utmpx_path" = x"no" ; then
- AC_DEFINE(DISABLE_UTMPX)
+ for f in /var/run/utmpx; do
+ if test -f $f ; then
+ conf_utmpx_location=$f
+ fi
+ done
+ if test -z "$conf_utmpx_location"; then
+ AC_DEFINE(DISABLE_UTMPX)
+ fi
fi
-else
+fi
+if test -n "$conf_utmpx_location"; then
AC_DEFINE_UNQUOTED(CONF_UTMPX_FILE, "$conf_utmpx_location")
fi
@@ -2849,9 +2860,17 @@ AC_TRY_COMPILE([
)
if test -z "$conf_wtmpx_location"; then
if test x"$system_wtmpx_path" = x"no" ; then
- AC_DEFINE(DISABLE_WTMPX)
+ for f in /var/log/wtmpx; do
+ if test -f $f ; then
+ conf_wtmpx_location=$f
+ fi
+ done
+ if test -z "$conf_wtmpx_location"; then
+ AC_DEFINE(DISABLE_WTMPX)
+ fi
fi
-else
+fi
+if test -n "$conf_wtmpx_location"; then
AC_DEFINE_UNQUOTED(CONF_WTMPX_FILE, "$conf_wtmpx_location")
fi
@@ -2892,7 +2911,7 @@ echo "OpenSSH has been configured with t
echo " User binaries: $B"
echo " System binaries: $C"
echo " Configuration files: $D"
-echo " Askpass program: $E"
+echo " Askpass program: ${ASKPASS_PROGRAM}"
echo " Manual pages: $F"
echo " PID file: $G"
echo " Privilege separation chroot path: $H"