b4178f25ff
qDecoder is a library for CGI programming. Being a Web Application Interface for C/C++ use, qDecoder is a solution product for developers. The Query Fetch algorithm of qDecoder based on the linked-list provides transparency with low layers by the simple library interface regardless of COOKIE/GET/POST(including File Upload). Thus, it enables the web based software to be more intuitively designed and implemented. qDecoder is developed according to the free software model and is publicly distributed.
129 lines
2.4 KiB
Text
129 lines
2.4 KiB
Text
$NetBSD: patch-aa,v 1.1.1.1 2002/05/04 00:53:51 jtb Exp $
|
|
|
|
--- src/Makefile.in.orig Thu Sep 6 16:33:39 2001
|
|
+++ src/Makefile.in Thu Apr 25 09:06:29 2002
|
|
@@ -37,87 +37,45 @@
|
|
# Name
|
|
PRGNAME = qDecoder
|
|
|
|
-# Static Library Name
|
|
-LIBNAME = lib${PRGNAME}.a
|
|
+# Library Name
|
|
+LIB = ${PRGNAME}
|
|
|
|
-# Shared Library Name
|
|
-SLIBVERSION = 2
|
|
-SLIBNAME = lib${PRGNAME}.so
|
|
-SLIBREALNAME = ${SLIBNAME}.${SLIBVERSION}
|
|
+# Shared Library Version
|
|
+SHLIB_MAJOR = 0
|
|
+SHLIB_MINOR = 0
|
|
|
|
# System library directory
|
|
LIBDIR = @libdir@
|
|
-HEADERDIR = @includedir@
|
|
|
|
-# Which compiler & options for release
|
|
-CC = @CC@
|
|
-CFLAGS = @CFLAGS@
|
|
-DEFS = @DEFS@
|
|
-INCLUDE = -I.
|
|
-
|
|
-# Utilities
|
|
-AR = @AR@
|
|
-ARFLAGS = -rc
|
|
-CHMOD = @CHMOD@
|
|
-INSTALL = @INSTALL@ -m 444
|
|
-LD = @LD@
|
|
-LDFLAGS = -G
|
|
-LN_S = @LN_S@
|
|
-RANLIB = @RANLIB@
|
|
-RM = @RM@
|
|
-
|
|
-
|
|
-# Objects List
|
|
-OBJ = qDecoder.o \
|
|
- qSession.o \
|
|
- qfDecoder.o \
|
|
- qsDecoder.o \
|
|
- qHttpHeader.o \
|
|
- qError.o \
|
|
- qEnv.o \
|
|
- qEncode.o \
|
|
- qString.o \
|
|
- qFile.o \
|
|
- qValid.o \
|
|
- qArg.o \
|
|
- qAwk.o \
|
|
- qSed.o \
|
|
- qCount.o \
|
|
- qDownload.o \
|
|
- qTime.o \
|
|
- qMisc.o \
|
|
- qInternalCommon.o \
|
|
- qInternalEntry.o \
|
|
- md5/md5c.o
|
|
-
|
|
-## Make Library
|
|
-all: ${OBJ}
|
|
- ${AR} ${ARFLAGS} ${LIBNAME} ${OBJ}
|
|
- ${RANLIB} ${LIBNAME}
|
|
- ${LD} ${LDFLAGS} -o ${SLIBREALNAME} ${OBJ}
|
|
- ${CHMOD} 0644 ${SLIBREALNAME}
|
|
- ${RM} -f ${SLIBNAME}
|
|
- ${LN_S} ${SLIBREALNAME} ${SLIBNAME}
|
|
-
|
|
-## Compile Module
|
|
-.c.o:
|
|
- ${CC} ${CFLAGS} ${DEFS} ${INCLUDE} -c -o $@ $<
|
|
-
|
|
-## Install Module
|
|
-install: all
|
|
- ${INSTALL} qDecoder.h ${HEADERDIR}/qDecoder.h
|
|
- ${INSTALL} ${LIBNAME} ${LIBDIR}/${LIBNAME}
|
|
- ${INSTALL} ${SLIBREALNAME} ${LIBDIR}/${SLIBREALNAME}
|
|
- ${RM} -f ${LIBDIR}/${SLIBNAME}
|
|
- ${LN_S} ${LIBDIR}/${SLIBREALNAME} ${LIBDIR}/${SLIBNAME}
|
|
-
|
|
-uninstall: deinstall
|
|
-deinstall:
|
|
- ${RM} -f ${HEADERDIR}/qDecoder.h
|
|
- ${RM} -f ${LIBDIR}/${LIBNAME}
|
|
- ${RM} -f ${LIBDIR}/${SLIBREALNAME}
|
|
- ${RM} -f ${LIBDIR}/${SLIBNAME}
|
|
-
|
|
-## Clear Module
|
|
-clean:
|
|
- ${RM} -f ${OBJ} ${LIBNAME} ${SLIBREALNAME} ${SLIBNAME}
|
|
+CPPFLAGS += @DEFS@ -I.
|
|
+
|
|
+NOLINT = 1
|
|
+NOPROFILE = 1
|
|
+
|
|
+# Sources List
|
|
+SRCS = qDecoder.c \
|
|
+ qSession.c \
|
|
+ qfDecoder.c \
|
|
+ qsDecoder.c \
|
|
+ qHttpHeader.c \
|
|
+ qError.c \
|
|
+ qEnv.c \
|
|
+ qEncode.c \
|
|
+ qString.c \
|
|
+ qFile.c \
|
|
+ qValid.c \
|
|
+ qArg.c \
|
|
+ qAwk.c \
|
|
+ qSed.c \
|
|
+ qCount.c \
|
|
+ qDownload.c \
|
|
+ qTime.c \
|
|
+ qMisc.c \
|
|
+ qInternalCommon.c \
|
|
+ qInternalEntry.c \
|
|
+ md5/md5c.c
|
|
+
|
|
+afterinstall:
|
|
+ ${BSD_INSTALL_DATA} qDecoder.h ${PREFIX}/include
|
|
+
|
|
+.include <bsd.lib.mk>
|