pkgsrc/sysutils/gkrellm/patches/patch-ai
cube 03b2910075 Update gkrellm packages to 2.2.5.
pkgsrc changes:
 o convert gkrellm-server to options.mk

GKrellM changes:
2.2.5 - Sun Mar 20, 2005
------------------------
        * Sensor monitor can read data from "mbmon -r -P port" daemon.
          mbmon and hddtemp daemon sensor monitor code moved to
          sysdeps/sensors-common.c to be available to all operating systems.
        * Hajimu Umemoto patch: added FreeBSD mbmon support.  Added general socket
          connection gkrellm_connect_to() function and cleaned up mail.c,
          client.c and sensors-common.c to use it.
        * Add api for gkrellmd plugins to have gkrellmd.conf config items.
          Gkrellmd plugins can read data sent from their gkrellm client plugins.
        * Keep history of daily, weekly & monthly net receive/transmit statistics.
        * Tom Felker patch: add to Linux sensors nVidia video card temperature
          reading via the nvidia-settings command.
        * Hajimu Umemoto patch: make gkrellmd support standard CIDR notation
          for both IPv4 and IPv6 allow-hosts.
        * Jiri Denemark patch: while charging, battery display shows time to
          full charge instead of discharge time left.  Make launcher work for
          all battery panels in case batteries are removed.
        * Try to make sensor labels fit better by using <small> markup.
        * Added option for mail fetch/check program to run at local check interval.
        * Bugfixes:
          o Jason Greene: IMAP patch fixes handling of status responses which
            contain literals.
          o Accumulate partial gkrellmd server lines.
          o Put minor mod numbers in Linux disk table to get c0d1, cc0d1, etc.
          o Segfault when rebuilding gkrellm if temp displayed on a disk panel.
          o Kim Bruning patch: display "no bat" if buggy APM flags don't flag
            when to hide batttery panel.
        * Translation updates
          o cs.po from Pav Lucistnik
          o da.po from Chris Larsen
2005-03-22 14:57:12 +00:00

22 lines
838 B
Text

$NetBSD: patch-ai,v 1.1 2005/03/22 14:57:12 cube Exp $
--- src/disk.c.orig 2005-03-06 18:04:22.000000000 +0100
+++ src/disk.c
@@ -487,7 +487,7 @@ gkrellm_disk_temperature_display(gpointe
{
disk = (DiskMon *) list->data;
if ( strncmp(disk->name, disk_name, len)
- || (disk->name[len] != '\0' && !isdigit(disk->name[len]))
+ || (disk->name[len] != '\0' && !isdigit((unsigned char)disk->name[len]))
)
continue;
if (!disk->enabled || !disk->chart || !disk->chart->panel->decal_list)
@@ -548,7 +548,7 @@ gkrellm_disk_temperature_remove(gchar *i
if (!disk->chart)
continue;
if ( strncmp(disk->name, disk_name, len)
- || (disk->name[len] != '\0' && !isdigit(disk->name[len]))
+ || (disk->name[len] != '\0' && !isdigit((unsigned char)disk->name[len]))
)
continue;
p = disk->chart->panel;