pkgsrc/net/arla/patches/patch-ae
wennmach 7d3f399204 Upgrade arla to 0.35.5
Most important changes:
o added user-land programs: kalog, aklog, arla-cli
o improved user-land programs: vos, bos, pts, etc.
o added man pages
o security fix (in rx)
o and tons of bug fixes

I included a start script to be placed under /etc/rc.d.
2001-08-09 13:48:58 +00:00

40 lines
1.4 KiB
Text

$NetBSD: patch-ae,v 1.3 2001/08/09 13:48:59 wennmach Exp $
Do not install libutil.a and the header files bool.h, hash.h, heap.h, list.h,
and log.h, nor any of the man pages. There is a potential conflict with other
libutils.
--- util/Makefile.in.orig Wed Oct 25 09:06:47 2000
+++ util/Makefile.in Fri Aug 3 14:41:35 2001
@@ -78,31 +78,8 @@
libutil_LIB: $(libutil_OBJS)
install: all
- $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
- $(INSTALL_DATA) $(LIB) $(DESTDIR)$(libdir)/$(LIB)
- for i in $(HEADERS); do \
- $(INSTALL_DATA) $(srcdir)/$$i $(DESTDIR)$(includedir)/$$i; \
- done ; \
- MANPAGES='$(MANPAGES)'; for x in $$MANPAGES; do \
- n=`echo $$x | sed 's/\(.*\)\.[1-9a-zA-Z]*$$/\1/'`; \
- e=`echo $$x | sed 's/.*\.\([1-9a-zA-Z]*\)$$/\1/'`; \
- f=`echo $$n | sed '$(transform)'`; \
- $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man$$e ; \
- $(INSTALL_DATA) $(srcdir)/$$x \
- $(DESTDIR)$(mandir)/man$$e/$$f.$$e; \
- done
uninstall:
- rm -f $(DESTDIR)$(libdir)/$(LIB)
- for i in $(HEADERS); do \
- rm -f $(DESTDIR)$(includedir)/$$i; \
- done ; \
- MANPAGES='$(MANPAGES)'; for x in $$MANPAGES; do \
- n=`echo $$x | sed 's/\(.*\)\.[1-9a-zA-Z]*$$/\1/'`; \
- e=`echo $$x | sed 's/.*\.\([1-9a-zA-Z]*\)$$/\1/'`; \
- f=`echo $$n | sed '$(transform)'`; \
- rm -rf $(DESTDIR)$(mandir)/$$f.$$e; \
- done
libutil.a: $(libutil_OBJS)
$(AR) cr $@ $(libutil_OBJS)