pkgsrc/mail/cyrus-imapd24/patches/patch-ac
gavan 9ff0abf568 Update cyrus-imapd24 to 2.4.20
Changes in 2.4.19:

  * Complete backport of the new (2.5 and later) IMAP IDLE implementation
    (thanks Thomas Jarosh). This fixes a bunch of bugs and race conditions
    that were inherent to the older implementation
  * New option "imapidletimeout" overrides "timeout" specifically for
    connections in IDLE state
  * OpenSSL 1.1.0 is now supported
  * Fixed: imap ENABLED doesn't print * ENABLED when nothing new enabled
  * Fixed: mailbox lock management over rename (thanks Thomas Jarosh)
  * Fixed: added overflow protection to urlfetch range checks
  * Fixed: lmtpd can now deliver when mupdate server isn't available
    (thanks Michael Menge)
  * Fixed task 227: service processes no longer divide by zero when
    invoked with -T 0 argument (thanks Ian Batten and Jens Erat)
  * Fixed task 229: ctl_cyrusdb now uses database paths from imapd.conf
    (thanks Simon Matter)
  * Fixed bug #3862: mailbox database changes now rolled back on mupdate
    failure during rename (thanks Michael Menge)
  * Fixed: XFER to 2.5 and later no longer downgrades index to oldest version
  * Fixed: nonsensical "TEXT.MIME" section now handled as "HEADER"
  * Fixed: added missing 'auditlog: ' prefix to backend connections
    (thanks Wolfgang Breyha)
  * Fixed: IMAP SEARCH crash on some platforms
  * Fixed: memory leaks in IMAP SEARCH and IMAP APPEND
  * Fixed Issue #1967: EXISTS count reported earlier if fetching past size
    of previous message set

Changes in 2.4.20:

  * Fixed: lmtpd crash
  * Fixed: auth_pts will now error if its configured socket path is too
    long for its buffer
2017-10-18 12:06:31 +00:00

35 lines
1.4 KiB
Text

$NetBSD: patch-ac,v 1.2 2017/10/18 12:06:31 gavan Exp $
--- imap/Makefile.in.orig 2010-10-19 03:08:28.000000000 +0000
+++ imap/Makefile.in
@@ -179,6 +179,9 @@ mupdate_err.c: mupdate_err.et
mupdate_err.h: mupdate_err.c
+mutex_pthread.o: mutex_pthread.c
+ $(CC) -c $(CPPFLAGS) $(DEFS) $(CFLAGS) $(PTHREAD_CFLAGS) $<
+
### Services
idled: idled.o idlemsg.o mutex_fake.o libimap.a $(DEPLIBS)
$(CC) $(LDFLAGS) -o idled \
@@ -213,16 +216,16 @@ imapd.quant: $(IMAPDOBJS) mutex_fake.o l
mupdate: mupdate.o mupdate-slave.o mupdate-client.o mutex_pthread.o tls.o \
libimap.a $(DEPLIBS)
- $(CC) $(LDFLAGS) -o mupdate \
+ $(CC) $(LDFLAGS) $(PTHREAD_LDFLAGS) -o mupdate \
$(SERVICETHREAD) mupdate.o mupdate-slave.o mupdate-client.o \
mutex_pthread.o tls.o libimap.a \
- $(DEPLIBS) $(LIBS) $(LIB_WRAP) -lpthread
+ $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(PTHREAD_LIBS)
mupdate.pure: mupdate.o mupdate-slave.o mupdate-client.o mutex_pthread.o \
libimap.a $(DEPLIBS)
- $(PURIFY) $(PUREOPT) $(CC) $(LDFLAGS) -o mupdate.pure \
+ $(PURIFY) $(PUREOPT) $(CC) $(LDFLAGS) $(PTHREAD_LDFLAGS) -o mupdate.pure \
$(SERVICETHREAD) mupdate.o mupdate-slave.o mupdate-client.o \
- mutex_pthread.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) -lpthread
+ mutex_pthread.o libimap.a $(DEPLIBS) $(LIBS) $(LIB_WRAP) $(PTHREAD_LIBS)
pop3d: pop3d.o proxy.o backend.o tls.o mutex_fake.o libimap.a \
$(DEPLIBS) $(SERVICE)