pkgsrc/devel/scmcvs/patches/patch-ac
martti a2ef7833f1 Updated devel/scmcvs to 1.11.22
* The CVS client again correctly reports files with conflicts when using
  servers running CVS 1.11.20/1.12.12, or earlier (and maybe 3rd party
  servers).

* The GSSAPI server should now build under HP-UX.

* `cvs rtag' now correctly tags files that have been removed from the trunk.

* Code efficiency has been improved slightly.

* A rare race condition that could leave a lock on the val-tags file has been
  avoided.

* A potential buffer overflow in the history command has been fixed.

* Thanks to a report and patch from Garrett Rooney <grooney@collab.net>, paused
  trigger processes no longer cause the CVS server to consume 100% CPU.

* Thanks to a suggestion from Joseph P. Skudlarek <Jskud@Jskud.com>, an
  :extssh: has been added as a synonym of the :ext: access method, as a
  kindness to users of old version of Eclipse.

* Misc documentation updates and minor bug fixes.
2008-01-04 06:48:05 +00:00

31 lines
1.1 KiB
Text

$NetBSD: patch-ac,v 1.2 2008/01/04 06:48:06 martti Exp $
--- src/Makefile.in.orig 2006-06-09 17:44:11.000000000 +0300
+++ src/Makefile.in 2008-01-02 14:43:16.000000000 +0200
@@ -86,7 +86,7 @@
version.$(OBJEXT) vers_ts.$(OBJEXT) watch.$(OBJEXT) \
wrapper.$(OBJEXT) zlib.$(OBJEXT)
cvs_OBJECTS = $(am_cvs_OBJECTS)
-cvs_DEPENDENCIES = ../diff/libdiff.a ../lib/libcvs.a ../zlib/libz.a
+cvs_DEPENDENCIES = ../diff/libdiff.a ../lib/libcvs.a
binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
SCRIPTS = $(bin_SCRIPTS)
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
@@ -200,7 +200,7 @@
# some namespace hackery going on that maybe shouldn't be. Long term fix is to
# try and remove naming ocnflicts and fix Automake to allow particular includes
# to be attached only to particular object files. Short term fix is either or.
-INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/diff -I$(top_srcdir)/zlib $(includeopt)
+INCLUDES = -I$(top_srcdir)/lib -I$(top_srcdir)/diff $(includeopt)
bin_SCRIPTS = cvsbug
# The cvs executable
@@ -279,7 +279,7 @@
cvs_LDADD = \
../diff/libdiff.a \
../lib/libcvs.a \
- ../zlib/libz.a
+ -lz
# extra clean targets