b330ca4a15
path to rman. The determination as to whether it's the package rman or the XFree86-4.x installed rman is left to bsd.pkg.mk (via USE_RMAN). Closes PR pkg/8755.
168 lines
4.9 KiB
Text
168 lines
4.9 KiB
Text
$NetBSD: patch-aa,v 1.18 2001/03/20 00:20:41 fredb Exp $
|
|
|
|
--- configure.orig Tue Sep 7 17:21:06 1999
|
|
+++ configure Sun Apr 2 23:16:38 2000
|
|
@@ -517,9 +517,10 @@
|
|
# Prefer explicitly selected file to automatically selected ones.
|
|
if test -z "$CONFIG_SITE"; then
|
|
if test "x$prefix" != xNONE; then
|
|
- CONFIG_SITE="$prefix/share/config.site $prefix/etc/config.site"
|
|
+ CONFIG_SITE="$prefix/share/kde/config.site $prefix/etc/config.site"
|
|
else
|
|
- CONFIG_SITE="$ac_default_prefix/share/config.site $ac_default_prefix/etc/config.site"
|
|
+ CONFIG_SITE="$ac_default_prefix/share/kde/config.site $ac_default_prefix/e
|
|
+tc/config.site"
|
|
fi
|
|
fi
|
|
for ac_site_file in $CONFIG_SITE; do
|
|
@@ -3994,37 +3995,37 @@
|
|
if test "$ac_use_path_checking" = "default"; then
|
|
|
|
if test -z "$kde_htmldir"; then
|
|
- kde_htmldir='\$(prefix)/share/doc/HTML'
|
|
+ kde_htmldir='\$(prefix)/share/doc/kde/HTML'
|
|
fi
|
|
if test -z "$kde_appsdir"; then
|
|
- kde_appsdir='\$(prefix)/share/applnk'
|
|
+ kde_appsdir='\$(prefix)/share/kde/applnk'
|
|
fi
|
|
if test -z "$kde_icondir"; then
|
|
- kde_icondir='\$(prefix)/share/icons'
|
|
+ kde_icondir='\$(prefix)/share/kde/kde/icons'
|
|
fi
|
|
if test -z "$kde_sounddir"; then
|
|
- kde_sounddir='\$(prefix)/share/sounds'
|
|
+ kde_sounddir='\$(prefix)/share/kde/sounds'
|
|
fi
|
|
if test -z "$kde_datadir"; then
|
|
- kde_datadir='\$(prefix)/share/apps'
|
|
+ kde_datadir='\$(prefix)/share/kde/apps'
|
|
fi
|
|
if test -z "$kde_locale"; then
|
|
- kde_locale='\$(prefix)/share/locale'
|
|
+ kde_locale='\$(prefix)/share/kde/locale'
|
|
fi
|
|
if test -z "$kde_cgidir"; then
|
|
- kde_cgidir='\$(exec_prefix)/cgi-bin'
|
|
+ kde_cgidir='\$(exec_prefix)/kde-cgi-bin'
|
|
fi
|
|
if test -z "$kde_confdir"; then
|
|
- kde_confdir='\$(prefix)/share/config'
|
|
+ kde_confdir='\$(prefix)/share/kde/config'
|
|
fi
|
|
if test -z "$kde_mimedir"; then
|
|
- kde_mimedir='\$(prefix)/share/mimelnk'
|
|
+ kde_mimedir='\$(prefix)/share/kde/mimelnk'
|
|
fi
|
|
if test -z "$kde_toolbardir"; then
|
|
- kde_toolbardir='\$(prefix)/share/toolbar'
|
|
+ kde_toolbardir='\$(prefix)/share/kde/toolbar'
|
|
fi
|
|
if test -z "$kde_wallpaperdir"; then
|
|
- kde_wallpaperdir='\$(prefix)/share/wallpapers'
|
|
+ kde_wallpaperdir='\$(prefix)/share/kde/wallpapers'
|
|
fi
|
|
if test -z "$kde_bindir"; then
|
|
kde_bindir='\$(exec_prefix)/bin'
|
|
@@ -4823,7 +4824,7 @@
|
|
echo $ac_n "(cached) $ac_c" 1>&6
|
|
else
|
|
ac_save_LIBS="$LIBS"
|
|
-LIBS="-lpam -ldl $LIBS"
|
|
+LIBS="-lpam $LIBS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
#line 4829 "configure"
|
|
#include "confdefs.h"
|
|
@@ -4847,7 +4848,7 @@
|
|
fi
|
|
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
|
echo "$ac_t""yes" 1>&6
|
|
- PASSWDLIB="-lpam -ldl"
|
|
+ PASSWDLIB="-lpam"
|
|
cat >> confdefs.h <<EOF
|
|
#define HAVE_PAM_LIB 1
|
|
EOF
|
|
@@ -5628,7 +5629,7 @@
|
|
|
|
ac_save_ldflags="$LDFLAGS"
|
|
ac_save_cflags="$CFLAGS"
|
|
- LDFLAGS="$LDFLAGS $GL_LDFLAGS $all_libraries -lMesaGL -lMesaGLU -lX11 -lXext -lm $LIBSOCKET"
|
|
+ LDFLAGS="$LDFLAGS $GL_LDFLAGS $all_libraries -lGL -lGLU -lX11 -lXext -lm $LIBSOCKET"
|
|
CFLAGS="$CFLAGS $X_INCLUDES"
|
|
test ! -z "$GL_INCLUDE" && CFLAGS="-I$GL_INCLUDE $CFLAGS"
|
|
cat > conftest.$ac_ext <<EOF
|
|
@@ -5665,9 +5666,9 @@
|
|
EOF
|
|
|
|
if test "$GL_LDFLAGS" = ""; then
|
|
- GLLIB='-lMesaGL -lMesaGLU $(LIB_X11)'
|
|
+ GLLIB='-lGL -lGLU $(LIB_X11)'
|
|
else
|
|
- GLLIB="$GL_LDFLAGS -lMesaGL -lMesaGLU "'$(LIB_X11)'
|
|
+ GLLIB="$GL_LDFLAGS -lGL -lGLU "'$(LIB_X11)'
|
|
fi
|
|
if test "$GL_INCLUDE" = ""; then
|
|
GLINC=""
|
|
@@ -6166,6 +6167,46 @@
|
|
|
|
|
|
|
|
+echo $ac_n "checking for main in -lossaudio""... $ac_c" 1>&6
|
|
+echo "configure:6171: checking for main in -lossaudio" >&5
|
|
+ac_lib_var=`echo ossaudio'_'main | sed 'y%./+-%__p_%'`
|
|
+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
|
+ echo $ac_n "(cached) $ac_c" 1>&6
|
|
+else
|
|
+ ac_save_LIBS="$LIBS"
|
|
+LIBS="-lossaudio $LIBS"
|
|
+cat > conftest.$ac_ext <<EOF
|
|
+#line 6179 "configure"
|
|
+#include "confdefs.h"
|
|
+
|
|
+int main() {
|
|
+main()
|
|
+; return 0; }
|
|
+EOF
|
|
+if { (eval echo configure:6186: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
|
+ rm -rf conftest*
|
|
+ eval "ac_cv_lib_$ac_lib_var=yes"
|
|
+else
|
|
+ echo "configure: failed program was:" >&5
|
|
+ cat conftest.$ac_ext >&5
|
|
+ rm -rf conftest*
|
|
+ eval "ac_cv_lib_$ac_lib_var=no"
|
|
+fi
|
|
+rm -f conftest*
|
|
+LIBS="$ac_save_LIBS"
|
|
+
|
|
+fi
|
|
+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
|
+ echo "$ac_t""yes" 1>&6
|
|
+ LIBOSSAUDIO=-lossaudio
|
|
+else
|
|
+ echo "$ac_t""no" 1>&6
|
|
+LIBOSSAUDIO=''
|
|
+fi
|
|
+
|
|
+
|
|
+
|
|
+
|
|
if test "$kde_have_setupterm" = "yes"; then
|
|
cat >> confdefs.h <<EOF
|
|
#define HAVE_SETUPTERM 1
|
|
@@ -7420,6 +7461,7 @@
|
|
s%@XPMLIB@%$XPMLIB%g
|
|
s%@XPM_SAVERS@%$XPM_SAVERS%g
|
|
s%@LIBCURSES@%$LIBCURSES%g
|
|
+s%@LIBOSSAUDIO@%$LIBOSSAUDIO%g
|
|
s%@LIBVOLMGT@%$LIBVOLMGT%g
|
|
s%@topdir@%$topdir%g
|
|
s%@RUN_KAPPFINDER@%$RUN_KAPPFINDER%g
|
|
@@ -7567,7 +7608,6 @@
|
|
kdehelp/Makefile \
|
|
kdehelp/index/Makefile \
|
|
kdehelp/search/Makefile \
|
|
- kdehelp/rman/Makefile \
|
|
kdm/Makefile \
|
|
kdm/config/Makefile \
|
|
kdm/config/kdmrc \
|