pkgsrc/archivers/lz4/patches/patch-programs_Makefile
adam 1be3a24628 lz4: updated to 1.9.1
LZ4 v1.9.1
Changes
fix : decompression functions were reading a few bytes beyond input size
api : fix : lz4frame initializers compatibility with c++
cli : added command --list
build: improved Windows build
build: AIX, by Norman Green

LZ4 v1.9.0
This release brings an assortment of small improvements and bug fixes, as detailed below :
perf: large decompression speed improvement on x86/x64 (up to +20%)
api : changed : _destSize() compression variants are promoted to stable API
api : new : LZ4_initStream(HC), replacing LZ4_resetStream(HC)
api : changed : LZ4_resetStream(HC) as recommended reset function, for better performance on small data
cli : support custom block sizes
build: source code can be amalgamated, by Bing Xu
build: added meson build
build: new build macros : LZ4_DISTANCE_MAX, LZ4_FAST_DEC_LOOP
install: MidnightBSD
install: msys2 on Windows 10
2019-04-30 09:17:38 +00:00

31 lines
1.2 KiB
Text

$NetBSD: patch-programs_Makefile,v 1.12 2019/04/30 09:17:39 adam Exp $
Unlock install target. Use pkgsrc install scripts.
--- programs/Makefile.orig 2019-04-23 17:18:40.000000000 +0000
+++ programs/Makefile
@@ -140,20 +140,20 @@ BINDIR ?= $(exec_prefix)/bin
bindir ?= $(BINDIR)
DATAROOTDIR ?= $(prefix)/share
datarootdir ?= $(DATAROOTDIR)
-MANDIR ?= $(datarootdir)/man
+MANDIR ?= $(PREFIX)/$(PKGMANDIR)
mandir ?= $(MANDIR)
MAN1DIR ?= $(mandir)/man1
man1dir ?= $(MAN1DIR)
install: lz4
@echo Installing binaries
- @$(INSTALL_DIR) $(DESTDIR)$(bindir)/ $(DESTDIR)$(man1dir)/
- @$(INSTALL_PROGRAM) lz4$(EXT) $(DESTDIR)$(bindir)/lz4$(EXT)
+ @$(BSD_INSTALL_PROGRAM_DIR) $(DESTDIR)$(bindir)/ $(DESTDIR)$(man1dir)/
+ @$(BSD_INSTALL_PROGRAM) lz4$(EXT) $(DESTDIR)$(bindir)/lz4$(EXT)
@$(LN_S) lz4$(EXT) $(DESTDIR)$(bindir)/lz4c$(EXT)
@$(LN_S) lz4$(EXT) $(DESTDIR)$(bindir)/lz4cat$(EXT)
@$(LN_S) lz4$(EXT) $(DESTDIR)$(bindir)/unlz4$(EXT)
@echo Installing man pages
- @$(INSTALL_DATA) lz4.1 $(DESTDIR)$(man1dir)/lz4.1
+ @$(BSD_INSTALL_MAN) lz4.1 $(DESTDIR)$(man1dir)/lz4.1
@$(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/lz4c.1
@$(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/lz4cat.1
@$(LN_SF) lz4.1 $(DESTDIR)$(man1dir)/unlz4.1