pkgsrc/mail/imap-uw/patches/patch-bg
jlam 25e4103cb1 * Split the MESSAGE file into two parts, one of which only shows up
if "ssl" is a package option.

* Stop the abuse of BUILD_TARGET and use MAKE_FLAGS instead.  Also,
  use OPSYSVARS to simplify the specification of the correct BUILD_TARGET
  for each platform.

* Make use of the EXTRASPECIALS variable used by imap makefiles to pass
  special MAKE_FLAGS settings through to all recursive make processes.
  This gets rid of some MAKE_ENV statements.

* Split off the special alpha-codegen hack into a hacks.mk file.

* Do man page fixups at post-build time, not post-extract time.  This
  leaves the files pristine for possible patching.

* Add back the special handling if IMAP_UW_MAILSPOOLHOME is defined.
  It was accidentally removed in patch-am when the whoson modifications
  were added.  Move the modifications to the configure phase instead
  of post-patch so that the modifications aren't accidentally picked
  up by mkpatches.

* Instead of listing each Makefile that needs the sed modification
  s/c-client.a/libc-client.la/ and modifying them at post-extract
  time, simply create patches for them.

* Instead of listing each header file to be installed, just derive
  the list from the PLIST.

* Make the libtoolification a bit more transparent by patching libtool
  references directly into the imap makefiles.

* Drop the -limapuw -> -lc-client buildlink transform that was only
  needed for much older versions of the imap-uw package, and stop
  installing libimapuw.*.  All dependents of imap-uw already correctly
  use -lc-client.

* Fix the handling of the kerberos package option so that we can use
  the pkgsrc Kerberos 5 packages instead of only using the native
  ones.

* Properly document the options.mk file.

Bump the PKGREVISION for the libimapuw.* changes and for the
IMAP_UW_MAILSPOOLHOME fixes.  The rest of the changes are all
pkgsrc-related and don't really affect the binary package.
2006-07-26 20:00:27 +00:00

22 lines
592 B
Text

$NetBSD: patch-bg,v 1.1 2006/07/26 20:00:27 jlam Exp $
--- src/mtest/Makefile.orig 2000-10-24 19:55:39.000000000 -0400
+++ src/mtest/Makefile
@@ -19,7 +19,7 @@
C = ../c-client
-CCLIENTLIB = $C/c-client.a
+CCLIENTLIB = $C/libc-client.la
SHELL = /bin/sh
# Get local definitions from c-client directory
@@ -31,7 +31,7 @@ LDFLAGS = $(CCLIENTLIB) `cat $C/LDFLAGS`
all: mtest
mtest: $(CCLIENTLIB) mtest.o
- $(CC) $(CFLAGS) -o mtest mtest.o $(LDFLAGS)
+ $(LTLINK) $(CC) $(CFLAGS) -o mtest mtest.o $(LDFLAGS)
mtest.o: $C/mail.h $C/misc.h $C/osdep.h $C/rfc822.h $C/smtp.h $C/nntp.h