strategy is to leave alone the install targets sprinkled all over the Makefiles and instead to two thigns: (1) Define new INST_* variants of BINDIR, ETCDIR, MODULEDIR, etc. that are the "final" installation locations, and thus may be hardcoded into the program. (2) Modify the definitions of BINDIR, ETCDIR, MODULEDIR, etc. to point to $(DESTDIR)$(INST_*). These variables can be used in the _install targets without any changes.
13 lines
450 B
Text
13 lines
450 B
Text
$NetBSD: patch-aj,v 1.3 2008/02/27 22:31:52 jlam Exp $
|
|
|
|
--- man/Makefile.orig 2004-07-28 23:10:32.000000000 -0400
|
|
+++ man/Makefile
|
|
@@ -22,7 +22,7 @@ include $(TOPDIR)/rules.mk
|
|
_install:
|
|
$(INSTALLDIR) $(MANDIR)/man1
|
|
$(INSTALL) -m $(DATA_MODE) ion.1 $(MANDIR)/man1
|
|
- $(INSTALL) -m $(DATA_MODE) pwm.1 $(MANDIR)/man1
|
|
+ $(INSTALL) -m $(DATA_MODE) pwm.1 $(MANDIR)/man1/pwm2.1
|
|
|
|
#
|
|
# Awful hack that may not work on the user's system. This is rule is
|