pkgsrc/graphics/magicpoint/patches/patch-aa
taca 2615325c03 Update magicpoint to 1.13a.
* Fix build error with xft2 option and graphics/freetype-lib package is
  installed.  Shoud be fix PR pkg/32656.
* Refering PR pkg/38552 adpot some of patches.
* Move PKG_OPTIONS related item to options.mk.
* More pkgsrc clean up.
* Try to reduce compile warnings.


What's new in 1.13a?

    * m17n library support enhancement
    * MacOS support enhancement
    * add new environment variable MGPRC for the path of the .mgprc file.
    * add "psfont" directive to specify the font used by mgp2ps
    * add -g option for mgp2ps to allow users to adjust line distanc
    * add -zoomonclk option for newimage
    * allow to handle gif format images by default
    * many bug fixes

      Dedication

      Magicpoint 1.13a is dedicated to the memory of Dr. Jun-ichiro
      "itojun" Hagino, who was known for his enormous contribution to
      the Internet and the Open Source Software community. He was the
      developer of Magicpoint from its infancy. Magicpoint could not
      exist without his devoted work.

What's new in 1.12a?

    * add %tsystem directive which might be more stable than %xsystem
    * add -rotate option for newimage
    * allow to use non-ASCI filename in slides (use -U to enable this feature)
    * many bug fixes
2008-09-10 13:32:47 +00:00

141 lines
4.9 KiB
Text

$NetBSD: patch-aa,v 1.11 2008/09/10 13:32:47 taca Exp $
--- configure.orig 2007-12-29 05:31:26.000000000 +0900
+++ configure
@@ -5090,7 +5090,7 @@ if test "$mgp_use_freetype" = "yes"; the
# XXX: freetype2 may use freetype-config
{ echo "$as_me:$LINENO: checking for freetype1 library/header" >&5
echo $ECHO_N "checking for freetype1 library/header... $ECHO_C" >&6; }
- for dir in $SEARCHPATH /usr/local/freetype /usr/local /opt/freetype /usr/pkg /usr /usr/include/freetype1 /sw; do
+ for dir in ${BUILDLINK_DIR}; do
ac_cv_ft_lib=no
ac_cv_ft_include=no
shlib=`echo $dir/lib/libttf.$SHLIBEXT* | head -n 1 | sed -e 's/.*\///'`
@@ -5384,7 +5384,7 @@ echo "${ECHO_T}$mgp_use_vflib" >&6; }
if test "$mgp_use_vflib" = "yes"; then
{ echo "$as_me:$LINENO: checking for VFlib library/header" >&5
echo $ECHO_N "checking for VFlib library/header... $ECHO_C" >&6; }
- for dir in $SEARCHPATH /usr/local/VFlib /usr/local/vflib /usr/local /usr/pkg /usr; do
+ for dir in ${BUILDLINK_DIR}; do
ac_cv_vf_libname=VFlib
ac_cv_vf_libdir=no
ac_cv_vf_hdrdir=no
@@ -5562,12 +5562,7 @@ fi
if test -f "$with_vfontcap"; then
ac_cv_vf_fontcap=$with_vfontcap;
else
- for ac_dir in /usr/local/lib /usr/local/lib/tex \
- /usr/local/lib/VFlib /usr/local/lib/fonts/vf \
- /usr/local/lib /usr/local/etc /etc \
- /usr/local/libdata/vflib /usr/local/share/VFlib \
- /usr/local/share/VFlib/* \
- ../../VFlib* ../VFlib* VFlib*; do
+ for ac_dir in ${prefix}/share/VFlib/*; do
if test -d $ac_dir -a -f $ac_dir/vfontcap; then
ac_cv_vf_fontcap=$ac_dir/vfontcap;
break
@@ -5609,22 +5604,17 @@ _ACEOF
fi
fi
-if type pkg-config > /dev/null 2>&1; then
- for pnglib in libpng libpng12 libpng10
- do
- if pkg-config $pnglib; then
- LIBS="$LIBS `pkg-config --libs $pnglib`"
- OPTFLAGS="$OPTFLAGS `pkg-config --cflags $pnglib`"
- cat >>confdefs.h <<\_ACEOF
+if type pkg-config > /dev/null 2>&1 && pkg-config libpng; then
+ LIBS="$LIBS `pkg-config --libs libpng`"
+ OPTFLAGS="$OPTFLAGS `pkg-config --cflags libpng`"
+ cat >>confdefs.h <<\_ACEOF
#define USE_PNG 1
_ACEOF
break
- fi
- done
fi
if test "$use_libpng" = ""; then
-for i in $SEARCHPATH /usr/pkg /usr/local /usr; do
+for i in ${BUILDLINK_DIR}; do
if test -f $i/include/png.h; then
if test -f $i/lib/libpng.a ; then
DEPLIBS="$DEPLIBS $i/lib/libpng.a"
@@ -5779,7 +5769,7 @@ fi
done
fi
-for i in /usr/pkg /usr/local /usr; do
+for i in ${BUILDLINK_DIR}; do
if test -f $i/include/libmng.h; then
if test -f $i/lib/libmng.a ; then
DEPLIBS="$DEPLIBS $i/lib/libmng.a"
@@ -6193,23 +6183,19 @@ fi
{ echo "$as_me:$LINENO: result: $mgp_use_xft2" >&5
echo "${ECHO_T}$mgp_use_xft2" >&6; }
if test "$mgp_use_xft2" = "yes"; then
- if type pkg-config > /dev/null 2>&1; then
- if pkg-config xft; then
- OPTFLAGS="`pkg-config --cflags xft` $OPTFLAGS"
- LIBS="$LIBS `pkg-config --libs xft`"
- cat >>confdefs.h <<\_ACEOF
+ if type pkg-config > /dev/null 2>&1 && pkg-config xft; then
+ OPTFLAGS="`pkg-config --cflags xft` $OPTFLAGS"
+ LIBS="$LIBS `pkg-config --libs xft`"
+ cat >>confdefs.h <<\_ACEOF
#define USE_XFT2 1
_ACEOF
mgp_xft2_found="yes";
- fi
fi
if test "$mgp_xft2_found" != "yes"; then
{ echo "$as_me:$LINENO: checking for xft2 and ft2 and fc header.." >&5
echo $ECHO_N "checking for xft2 and ft2 and fc header..... $ECHO_C" >&6; }
- for dir in /usr/include /usr/include/Xft2 /usr/X11R6/include \
- /usr/X11R6/include/freetype2 \
- /usr/local/include /usr/include/freetype2; do
+ for dir in ${BUILDLINK_DIR}; do
if test -f $dir/X11/Xft/Xft.h; then
ac_cv_xft2_hdrdir="$dir"
fi
@@ -6984,7 +6970,7 @@ fi
echo 'FATAL: You need libungif to use gif images. pass proper LIBS to configure.'
exit 1
fi
- for i in /usr/pkg /usr/local /usr; do
+ for i in ${BUILDLINK_DIR}; do
if test -f $i/include/gif_lib.h; then
gif_h_ok=yes
OPTFLAGS="$OPTFLAGS -I$i/include"
@@ -7146,16 +7132,14 @@ fi
{ echo "$as_me:$LINENO: result: $mgp_imlib" >&5
echo "${ECHO_T}$mgp_imlib" >&6; }
if test $mgp_imlib = "yes"; then
- if type pkg-config > /dev/null 2>&1; then
- if pkg-config imlib; then
- LIBS="$LIBS `pkg-config --libs imlib`"
- OPTFLAGS="$OPTFLAGS `pkg-config --cflags imlib`"
- cat >>confdefs.h <<\_ACEOF
+ if type pkg-config > /dev/null 2>&1 && pkg-config imlib; then
+ LIBS="$LIBS `pkg-config --libs imlib`"
+ OPTFLAGS="$OPTFLAGS `pkg-config --cflags imlib`"
+ cat >>confdefs.h <<\_ACEOF
#define USE_IMLIB 1
_ACEOF
USE_IMLIB=1
- fi
else
{ echo "$as_me:$LINENO: checking for Imlib_init in -lImlib" >&5
echo $ECHO_N "checking for Imlib_init in -lImlib... $ECHO_C" >&6; }
@@ -7232,7 +7216,7 @@ fi
echo 'FATAL: You need libImlib to use Imlib loading. pass proper LIBS to configure.'
exit 1
fi
- for i in /usr/pkg /usr/local; do
+ for i in ${BUILDLINK_DIR}; do
if test -f $i/include/Imlib.h; then
imlib_h_ok=yes
OPTFLAGS="$OPTFLAGS -I$i/include"