21 lines
717 B
Text
21 lines
717 B
Text
$NetBSD: patch-ah,v 1.8 2015/12/29 23:34:49 dholland Exp $
|
|
|
|
Be consistent and always link rt.jar. It seems like the creation was
|
|
timing dependent. Fixes PR 42458.
|
|
|
|
--- libraries/javalib/Makefile.in.orig 2009-12-22 11:10:05.000000000 +0000
|
|
+++ libraries/javalib/Makefile.in
|
|
@@ -1275,11 +1275,8 @@ clean-local:
|
|
export JAVA_COMPILER
|
|
|
|
install-data-local: installdirs
|
|
- if test -f $(DESTDIR)${jrelibdir}/glibj.zip ; then \
|
|
- if ! test -f $(DESTDIR)${jrelibdir}/rt.jar ; then \
|
|
- $(LN_S) $(DESTDIR)${jrelibdir}/glibj.zip $(DESTDIR)${jrelibdir}/rt.jar ; \
|
|
- fi ; \
|
|
- fi
|
|
+ rm -f $(DESTDIR)${jrelibdir}/rt.jar
|
|
+ $(LN_S) glibj.zip $(DESTDIR)${jrelibdir}/rt.jar
|
|
|
|
uninstall-local:
|
|
$(RM) $(DESTDIR)${jrelibdir}/rt.jar
|