1c70f097e8
Changes since last packaged version (1.12) September 14, 2004 - release 1.16 dotneato - fix bugs: 275, 523, 526, 527, 529, 534 August 30, 2004 - release 1.14 dotneato - the official gd now has support support for GIFs again - the internal gd is now closely sync'ed with the official version and will eventually be removed in favor of using a separate installation of the official version. - gd has new support for FontConfig (thanks to Dag Lem) NB. the fontname attribute in graphs is now a font pattern as understood by fontconfig (e.g. fontname="Times-Italic"), unless it contains a '/' in which case it is interpreted as a font path as before. - gd provides support for html4 entities in decimal, hex or named, e.g "<" - "dot -v" debugging output now reports fontname -> fontpath resolutions - PostScript generated by -Tps now uses "xshow" operator for strings for better matching of bitmap and PostScript outputs. - ability to use an external gd-2.0.29 version of libgd (EXPERIMENTAL) - new feature: parallel edges by using a ":" separated list of edge colors - new feature: rankdir=BT and rankdir=RL (thanks to Dag Lem) - new layout engine: fdp - force directed placement (EXPERIMENTAL) a neato-like undirected layout engine that produces clustered symmetric layouts. Supports edges between clusters and nodes. - updated neato engine: now using stress majorization as the default, which avoids the potential for cycling - model=subset in neato provides a third distance function, where two nodes sharing many nodes will be place farther apart - shape=none now equivalent to shape=plaintext - fix label justification with \l and \r - first cut at <FONT> support added to html labels - various color transparency fixes - various fixes for UTF8 and Latin[12] character encodings. - various cluster fixes. - improved hyperlink support in -Tsvg - support tooltips on clusters in client-side imagemaps gvpr - add support for scanf and friends general - greater use of shared libraries. - pkg-config files provided for shared libraries (EXPERIMENTAL) - "./configure --disable-shared --enable-static" works if needed - C++ wrappers on all header files (thanks to Victor Wodecki) - various configuration and portablity fixes - provide pdf version of man pages - Windows package provides graphviz libraries and header files - Closed bugs: 195, 198, 234, 321, 330, 399, 401, 406, 410, 411, 412, 413, 415, 416, 417, 423, 424, 427, 430, 431, 433, 434, 435, 438, 441, 442, 444, 445, 449, 450, 452, 454, 457, 458, 462, 463, 464, 467, 468, 469, 471, 475, 480, 482, 485, 495, 496, 498, 499, 500, 501, 504, 508, 511, 512, 514 March 5, 2004 - added glyphwidths.ps support utility
135 lines
4.5 KiB
Text
135 lines
4.5 KiB
Text
$NetBSD: patch-be,v 1.1 2004/11/29 22:11:51 seb Exp $
|
|
|
|
--- gdtclft/Makefile.in.orig 2004-09-14 22:13:16.000000000 +0000
|
|
+++ gdtclft/Makefile.in
|
|
@@ -14,7 +14,6 @@
|
|
|
|
@SET_MAKE@
|
|
|
|
-
|
|
SOURCES = $(libgdtclft_la_SOURCES)
|
|
|
|
srcdir = @srcdir@
|
|
@@ -55,8 +54,7 @@ am__vpath_adj = case $$p in \
|
|
*) f=$$p;; \
|
|
esac;
|
|
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
|
|
-am__installdirs = "$(DESTDIR)$(pkglibdir)" "$(DESTDIR)$(manndir)" \
|
|
- "$(DESTDIR)$(pdfdir)"
|
|
+am__installdirs = "$(DESTDIR)$(pkglibdir)" "$(DESTDIR)$(manndir)"
|
|
pkglibLTLIBRARIES_INSTALL = $(INSTALL)
|
|
LTLIBRARIES = $(pkglib_LTLIBRARIES)
|
|
libgdtclft_la_DEPENDENCIES = \
|
|
@@ -87,8 +85,6 @@ RECURSIVE_TARGETS = all-recursive check-
|
|
manndir = $(mandir)/mann
|
|
NROFF = nroff
|
|
MANS = $(man_MANS)
|
|
-pdfDATA_INSTALL = $(INSTALL_DATA)
|
|
-DATA = $(pdf_DATA)
|
|
ETAGS = etags
|
|
CTAGS = ctags
|
|
DIST_SUBDIRS = $(SUBDIRS)
|
|
@@ -192,7 +188,6 @@ SOCKET_LIBS = @SOCKET_LIBS@
|
|
SORT = @SORT@
|
|
STRIP = @STRIP@
|
|
TCLINT_INCLUDES = @TCLINT_INCLUDES@
|
|
-TCLSH = @TCLSH@
|
|
TCL_CFLAGS = @TCL_CFLAGS@
|
|
TCL_DEFS = @TCL_DEFS@
|
|
TCL_INCLUDES = @TCL_INCLUDES@
|
|
@@ -218,7 +213,6 @@ TK_VERSION = @TK_VERSION@
|
|
TK_XINCLUDES = @TK_XINCLUDES@
|
|
TOP_DIR = @TOP_DIR@
|
|
VERSION = @VERSION@
|
|
-WISH = @WISH@
|
|
WITH_MYLIBGD_FALSE = @WITH_MYLIBGD_FALSE@
|
|
WITH_MYLIBGD_TRUE = @WITH_MYLIBGD_TRUE@
|
|
WITH_TCL_FALSE = @WITH_TCL_FALSE@
|
|
@@ -294,10 +288,8 @@ AM_CPPFLAGS = \
|
|
AM_CFLAGS = @TCL_CFLAGS@
|
|
man = gdtclft.n
|
|
pdf = gdtclft.pdf
|
|
-pdfdir = $(pkgdatadir)/doc/pdf
|
|
@WITH_TCL_TRUE@pkglib_LTLIBRARIES = libgdtclft.la
|
|
@WITH_TCL_TRUE@man_MANS = $(man)
|
|
-@WITH_TCL_TRUE@pdf_DATA = $(pdf)
|
|
libgdtclft_la_SOURCES = gdtclft.c
|
|
libgdtclft_la_LIBADD = \
|
|
$(top_builddir)/tclhandle/libtclhandle.la \
|
|
@@ -452,23 +444,6 @@ uninstall-mann:
|
|
echo " rm -f '$(DESTDIR)$(manndir)/$$inst'"; \
|
|
rm -f "$(DESTDIR)$(manndir)/$$inst"; \
|
|
done
|
|
-install-pdfDATA: $(pdf_DATA)
|
|
- @$(NORMAL_INSTALL)
|
|
- test -z "$(pdfdir)" || $(mkdir_p) "$(DESTDIR)$(pdfdir)"
|
|
- @list='$(pdf_DATA)'; for p in $$list; do \
|
|
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
|
- f=$(am__strip_dir) \
|
|
- echo " $(pdfDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pdfdir)/$$f'"; \
|
|
- $(pdfDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pdfdir)/$$f"; \
|
|
- done
|
|
-
|
|
-uninstall-pdfDATA:
|
|
- @$(NORMAL_UNINSTALL)
|
|
- @list='$(pdf_DATA)'; for p in $$list; do \
|
|
- f=$(am__strip_dir) \
|
|
- echo " rm -f '$(DESTDIR)$(pdfdir)/$$f'"; \
|
|
- rm -f "$(DESTDIR)$(pdfdir)/$$f"; \
|
|
- done
|
|
|
|
# This directory's subdirectories are mostly independent; you can cd
|
|
# into them and run `make' without going through this Makefile.
|
|
@@ -635,10 +610,10 @@ distdir: $(DISTFILES)
|
|
check-am: all-am
|
|
check: check-recursive
|
|
@WITH_TCL_FALSE@all-local:
|
|
-all-am: Makefile $(LTLIBRARIES) $(MANS) $(DATA) all-local
|
|
+all-am: Makefile $(LTLIBRARIES) $(MANS) all-local
|
|
installdirs: installdirs-recursive
|
|
installdirs-am:
|
|
- for dir in "$(DESTDIR)$(pkglibdir)" "$(DESTDIR)$(manndir)" "$(DESTDIR)$(pdfdir)"; do \
|
|
+ for dir in "$(DESTDIR)$(pkglibdir)" "$(DESTDIR)$(manndir)"; do \
|
|
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
|
done
|
|
install: install-recursive
|
|
@@ -688,7 +663,7 @@ info: info-recursive
|
|
|
|
info-am:
|
|
|
|
-install-data-am: install-man install-pdfDATA
|
|
+install-data-am: install-man
|
|
|
|
install-exec-am: install-pkglibLTLIBRARIES
|
|
|
|
@@ -716,7 +691,7 @@ ps: ps-recursive
|
|
|
|
ps-am:
|
|
|
|
-uninstall-am: uninstall-info-am uninstall-man uninstall-pdfDATA \
|
|
+uninstall-am: uninstall-info-am uninstall-man \
|
|
uninstall-pkglibLTLIBRARIES
|
|
|
|
uninstall-info: uninstall-info-recursive
|
|
@@ -731,14 +706,13 @@ uninstall-man: uninstall-mann
|
|
dvi dvi-am html html-am info info-am install install-am \
|
|
install-data install-data-am install-exec install-exec-am \
|
|
install-info install-info-am install-man install-mann \
|
|
- install-pdfDATA install-pkglibLTLIBRARIES install-strip \
|
|
- installcheck installcheck-am installdirs installdirs-am \
|
|
- maintainer-clean maintainer-clean-generic \
|
|
- maintainer-clean-recursive mostlyclean mostlyclean-compile \
|
|
- mostlyclean-generic mostlyclean-libtool mostlyclean-recursive \
|
|
- pdf pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
|
|
- uninstall-info-am uninstall-man uninstall-mann \
|
|
- uninstall-pdfDATA uninstall-pkglibLTLIBRARIES
|
|
+ install-pkglibLTLIBRARIES install-strip installcheck \
|
|
+ installcheck-am installdirs installdirs-am maintainer-clean \
|
|
+ maintainer-clean-generic maintainer-clean-recursive \
|
|
+ mostlyclean mostlyclean-compile mostlyclean-generic \
|
|
+ mostlyclean-libtool mostlyclean-recursive pdf pdf-am ps ps-am \
|
|
+ tags tags-recursive uninstall uninstall-am uninstall-info-am \
|
|
+ uninstall-man uninstall-mann uninstall-pkglibLTLIBRARIES
|
|
|
|
|
|
@WITH_TCL_TRUE@all-local: pkgIndex.tcl
|