5debe19e0c
Version 8.1.6 ------------- * Bug fixes Version 8.1.5 ------------- * Bug fixes Version 8.1.4 ------------- Milestone version: over 1000 patches since the last from Sun * Bug fixes * Enhancements * qacct: print category information; support -A like -P ; make -u a synonym for -o; -E selects on job end times read from standard input with -f * Move manager/operator setup in startup scripts * Installation creates an environment modules file * Add monitor_qmaster.sh script * Write shepherd panic messages to syslog, not into /tmp * Add .desktop file for qmon * rpm/dpkg packaging allows building against motif (recent Debian/Fedora) * Accounting reports qmaster-enforced resource limits (only on master PE task if accounting_summary is false) * Add "smp" to the default queue PE list * install_execd doesn't check the presence of (mostly irrelevant) binaries * Add configuration for logcheck * Potentially incompatible changes * renew_all_certs.ksh re-named to renew_all_certs.sh * Expand $ja_task_id to 0 for non-array jobs * Move manager/operator setup in startup scripts * For security reasons, installation defaults for min_uid, min_gid in sge_conf(5) are now 100 without CSP. See <http://arc.liv.ac.uk/SGE/howto/sge-security.html> * RPM layout changed to put relevant ones under noarch (on RHEL6 and recent Fedora), with a separate guiinst package * Memory values can be input and output in TB or tB (possible incompatibility parsing output) * Reduce execd CPU time reading large smaps files from Linux /proc and provide USE_SMAPS in execd_params to turn it on (default now off because huge smaps are generated by some programs) * Remove redundant -verify option from qsh, qlogin (per doc) Version 8.1.3 ------------- * Bug fixes * Enhancements * Document Interix building explicitly * qstat reports array task maximum concurrency * qstatus removes [] suffix for non-array jobs if -t was requested * Read /etc/default/{sgeexecd,sgemaster} to allow customizing rc scripts * Location of daemon pid files can be specified with SGE_QMASTER_PIDFILE, SGE_EXECD_PIDFILE * Debian packaging (as an add-on, installing into /opt/sge) * Expand $sge_root and $sge_cell in the definitions of prolog and similar methods * Check in init script that shepherd will load * Add lx-armhf architecture * On Linux and NetBSD, report jobs' virtual memory usage as accurately as possible * Add -nobincheck installation option to avoid checking binaries * Add some build hooks, useful for Debian particularly. * Potentially incompatible changes * qacct prints units (might affect parsing the output) * Correct spelling of "comunication_error" in qstat XML error output * Fix problems submitting to ARs (printing times now doesn't use a days field in qstat etc.) * Java version >= 1.5 required * Lower default MAX_DYN_EC somewhat to avoid warning on typical Linux configurations * Other changes * Don't install the ckpt directory (contents obsolete) Version 8.1.2 ------------- * Bug fixes * Enhancements * Use cpusets for process containment on fairly recent Linux-based systems (see USE_CGROUPS in sge_conf(5)) * Add bootstrap build script * Make SGE template an RPM conf file * Incompatible changes * Make CRL and certificate expiry consistent Version 8.1.1 ------------- * Bug fixes * Security * Don't pass any user environment to remote startup daemons -- better fix for half of CVE-2012-0208 * Enhancements * SGE_BINDING is set in the environment for all types of binding * New jobstats(1) provides historical job summary * Berkeleydb spools can optionally be opened "private" to allow operation on NFS3 filesystems. Currently no installer support, but see bootstrap(5) and the health warning * Environment variable SGE_DRMAA_ALLOW_JOB_ERROR_STATE allows DRMAA jobs to enter the error state; see drmaa_submit(3) * Define SGE_JOBEXIT_STAT environment variable in epilog; see submit(1) * The user from which mail is sent can be configured in sge_conf(5) * Topology items are now static load values; see load_parameters(5) * qstat now prints array job dependency info * Default to support for qsort_args in sge_pe(5) * Include an example of logrotate usage * Install an "smp" PE * Distribute/document sge_share_mon(1) to print share tree * Improve install template defaults * GPU load sensor (dist/util/resources/loadsensors/gpu-loadsensor.c) * Allow building Kerberos/GSSAPI security modules against Heimdal (but GSS is still not properly usable) * Support arm and mipsel on GNU/Linux, completing the set of official Debian Linux-based ports * Support for OpenBSD (untested) * Preliminary support for Cygwin: everything builds, clients work (lightly tested), daemons need fixing * Add ja_task_id to expandable variables in ckpt_command and similar methods * distinst supports installation with install(1) for use with -local * Incompatible changes * The CA directory is now /var/lib/sgeCA instead of /var/sgeCA but installation will offer to move it [fixme] * Drop (any pretence at) support for Cray/Unicos, NEC SX, Darwin 6 * The spool format for parallel job tasks has changed from any previous version built with qsort_args (as above), which will make live upgrades from such a version fail on nodes running parallel jobs * Other changes * Extensive internal changes to improve robustness, e.g. of string-handling against buffer overruns -- somewhat error-prone and may have caused regressions; more required * Install script allows rsh et al to be omitted from binary distribution in favour of ssh Version 8.1.0 ------------- * Security fix * Prevent users other than root deleting entries with sgepasswd * Version numbering * Switch to a more logical numbering scheme now that the Univa baseline is irrelevant * Bug fixes * Other changes * Hadoop support now for a more recent Hadoop distribution (see README.BUILD) Version 8.0.0e -------------- Mostly build and security issues * Bug fixes * Security fixes The first fix is for a trivial remote root by a valid user. The others, including fixes for potential buffer overruns in daemon and setuid programs, may or may not be exploitable. * Sanitize the environment before executing remote startup programs etc. Somewhat incompatible: LD_LIBRARY_PATH etc. may need to be set differently. See the security notes in remote_startup(5) and sge_conf(5). (CVE-2012-0208, thanks to William Hay) * Don't write initial log messages in /tmp. Somewhat incompatible: initial messages now in syslog. * Avoid using mktemp. (Probably not a significant problem.) * Control core dumps under setuid etc. with SGE_ENABLE_COREDUMP. (Not normally a security issue.) * Bounds checking in replace_params * Avoid execd crash and possible overruns * Fixes for buffer overrun and other improvements for (setuid program) sgepasswd
125 lines
7.8 KiB
Text
125 lines
7.8 KiB
Text
$NetBSD: patch-source-utilbin_Makefile,v 1.2 2014/01/14 10:21:39 markd Exp $
|
|
|
|
Add LDFLAGS
|
|
replace $(COMMLISTSLIB) with -lcommlists so that pkgsrc wrapper
|
|
doesnt reorder.
|
|
|
|
--- source/utilbin/Makefile.orig 2013-10-28 16:22:54.000000000 +0000
|
|
+++ source/utilbin/Makefile
|
|
@@ -118,14 +118,14 @@ gethostbyaddr.o: $(UTILBIN_DIR)/gethostb
|
|
|
|
#---------------------------------------------------------------------
|
|
getservbyname: getservbyname.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(LFLAGS) getservbyname.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(DLLIB) $(LIBS)
|
|
+ $(CC) $(CFLAGS) -o $@ $(LFLAGS) getservbyname.o version.o -luti $(WINGRIDLIB) -lcommlists $(DLLIB) $(LIBS)
|
|
|
|
getservbyname.o: $(UTILBIN_DIR)/getservbyname.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/getservbyname.c
|
|
|
|
#---------------------------------------------------------------------
|
|
filestat: filestat.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(LFLAGS) filestat.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) $(CFLAGS) -o $@ $(LFLAGS) filestat.o version.o -luti $(WINGRIDLIB) -lcommlists $(LIBS)
|
|
|
|
filestat.o: $(UTILBIN_DIR)/filestat.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/filestat.c
|
|
@@ -146,28 +146,28 @@ read_raw.o: $(UTILBIN_DIR)/read_raw.c
|
|
|
|
#---------------------------------------------------------------------
|
|
echo_raw: echo_raw.o version.o $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(LFLAGS) echo_raw.o version.o -luti $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) $(CFLAGS) -o $@ $(LFLAGS) echo_raw.o version.o -luti -lcommlists $(LIBS)
|
|
|
|
echo_raw.o: $(UTILBIN_DIR)/echo_raw.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/echo_raw.c
|
|
|
|
#---------------------------------------------------------------------
|
|
checkprog: checkprog.o peopen_standalone.o pids_standalone.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(LFLAGS) checkprog.o peopen_standalone.o pids_standalone.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(LIBS) $(DLLIB)
|
|
+ $(CC) $(CFLAGS) -o $@ $(LFLAGS) checkprog.o peopen_standalone.o pids_standalone.o version.o -luti $(WINGRIDLIB) -lcommlists $(LIBS) $(DLLIB)
|
|
|
|
checkprog.o: $(UTILBIN_DIR)/checkprog.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/checkprog.c
|
|
|
|
#---------------------------------------------------------------------
|
|
checkuser: checkuser.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) $(CFLAGS) -o $@ $(LFLAGS) checkuser.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) $(CFLAGS) -o $@ $(LFLAGS) checkuser.o version.o -luti $(WINGRIDLIB) -lcommlists $(LIBS)
|
|
|
|
checkuser.o: $(UTILBIN_DIR)/checkuser.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/checkuser.c
|
|
|
|
#---------------------------------------------------------------------
|
|
adminrun: adminrun.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) -o $@ $(LFLAGS) adminrun.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) adminrun.o version.o -luti $(WINGRIDLIB) -lcommlists $(LIBS)
|
|
|
|
adminrun.o: $(UTILBIN_DIR)/adminrun.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/adminrun.c
|
|
@@ -188,7 +188,7 @@ signals.o: $(UTILBIN_DIR)/signals.c
|
|
|
|
#---------------------------------------------------------------------
|
|
loadcheck: loadcheck.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB) $(SGEOBJLIB) $(SGEOBJDLIB) $(CULLLIB) binding_support.o
|
|
- $(CC) -o $@ $(LFLAGS) loadcheck.o version.o binding_support.o $(SGEOBJLIB) $(SGEOBJDLIB) $(CULLLIB) $(UTILIB) $(WINGRIDLIB) $(COMMLISTSLIB) $(LOADAVGLIBS) $(HWLOCLIB) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) loadcheck.o version.o binding_support.o $(SGEOBJLIB) $(SGEOBJDLIB) $(CULLLIB) $(UTILIB) $(WINGRIDLIB) -lcommlists $(LOADAVGLIBS) $(HWLOCLIB) $(LIBS)
|
|
|
|
loadcheck.o: $(UTILBIN_DIR)/loadcheck.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/loadcheck.c
|
|
@@ -203,26 +203,26 @@ loadcheck.obj: $(UTILBIN_DIR)/loadcheck.
|
|
|
|
#---------------------------------------------------------------------
|
|
languagetest: languagetest.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) -o $@ $(LFLAGS) languagetest.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) languagetest.o version.o -luti $(WINGRIDLIB) -lcommlists $(LIBS)
|
|
|
|
languagetest.o: $(UTILBIN_DIR)/languagetest.c
|
|
$(CC) $(CFLAGS) $(GCC_NODUPLWARN) -c $(UTILBIN_DIR)/languagetest.c
|
|
#---------------------------------------------------------------------
|
|
infotext: infotext.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) -o $@ $(LFLAGS) infotext.o version.o -luti $(WINGRIDLIB) $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) infotext.o version.o -luti $(WINGRIDLIB) -lcommlists $(LIBS)
|
|
|
|
infotext.o: $(UTILBIN_DIR)/infotext.c
|
|
$(CC) $(CFLAGS) $(GCC_NODUPLWARN) -c $(UTILBIN_DIR)/infotext.c
|
|
|
|
#---------------------------------------------------------------------
|
|
fstype: fstype.o version.o $(WINGRIDLIB_DEP) $(COMMLISTSLIB) $(UTILIB)
|
|
- $(CC) -o $@ $(LFLAGS) fstype.o version.o $(WINGRIDLIB) $(FSTYPELIBS) -luti $(COMMLISTSLIB) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) fstype.o version.o $(WINGRIDLIB) $(FSTYPELIBS) -luti -lcommlists $(LIBS)
|
|
|
|
fstype.o: $(UTILBIN_DIR)/fstype.c
|
|
$(CC) $(CFLAGS) $(MEMCFLAG) $(GCC_NODUPLWARN) -c $(UTILBIN_DIR)/fstype.c
|
|
#---------------------------------------------------------------------
|
|
spooldefaults: spooldefaults.o version.o sge_mt_init.o $(SPOOLING_DEPS) $(SPOOLCLIB) $(SPOOLLIB) $(SCHEDLIB) $(EVCLIB) $(GDILIB) $(SGEOBJLIB) $(SGEOBJDLIB) $(COMMLIB) $(COMMLISTSLIB) $(CULLLIB) $(WINGRIDLIB_DEP) $(UTILIB)
|
|
- $(CC) -o $@ $(LFLAGS) spooldefaults.o version.o sge_mt_init.o -lspoolc $(SPOOLING_LIBS) -lsched -levc -lgdi -lsgeobj -lsgeobjd $(KRBLIB) -lcull -lcomm -lcommlists -luti $(SECLIB) $(WINGRIDLIB) $(DLLIB) $(SLIBS) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) spooldefaults.o version.o sge_mt_init.o $(LDFLAGS) -lspoolc $(SPOOLING_LIBS) -lsched -levc -lgdi -lsgeobj -lsgeobjd $(KRBLIB) -lcull -lcomm -lcommlists -luti $(SECLIB) $(WINGRIDLIB) $(DLLIB) $(SLIBS) $(LIBS)
|
|
|
|
spooldefaults.o: $(UTILBIN_DIR)/spooldefaults.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/spooldefaults.c
|
|
@@ -236,7 +236,7 @@ spoolinit.o: $(UTILBIN_DIR)/spoolinit.c
|
|
|
|
#---------------------------------------------------------------------
|
|
testsuidroot: testsuidroot.o version.o $(WINGRIDLIB_DEP) $(UTILIB) $(COMMLISTSLIB)
|
|
- $(CC) -o $@ $(LFLAGS) testsuidroot.o version.o -luti $(COMMLISTSLIB) $(WINGRIDLIB) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) testsuidroot.o version.o -luti -lcommlists $(WINGRIDLIB) $(LIBS)
|
|
|
|
testsuidroot.o: $(UTILBIN_DIR)/testsuidroot.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/testsuidroot.c
|
|
@@ -257,7 +257,7 @@ tst_pthread_signals.o: $(UTILBIN_DIR)/ts
|
|
|
|
#---------------------------------------------------------------------
|
|
spooledit: spooledit.o sge_mt_init.o $(SPOOLING_DEPS) $(SPOOLLIB) $(SCHEDLIB) $(EVCLIB) $(GDILIB) $(SGEOBJLIB) $(SGEOBJDLIB) $(COMMLIB) $(COMMLISTSLIB) $(CULLLIB) $(WINGRIDLIB_DEP) $(UTILIB)
|
|
- $(CC) -o $@ $(LFLAGS) spooledit.o version.o sge_mt_init.o -lspoolb $(SPOOLING_LIBS) -lsched -levc -lgdi -lsgeobj -lsgeobjd $(KRBLIB) -lcull -lcomm -lcommlists -luti $(SECLIB) $(WINGRIDLIB) -ldb$(BDB_LIB_SUFFIX) $(DLLIB) $(SLIBS) $(LIBS)
|
|
+ $(CC) -o $@ $(LFLAGS) spooledit.o version.o sge_mt_init.o $(LDFLAGS) -lspoolb $(SPOOLING_LIBS) -lsched -levc -lgdi -lsgeobj -lsgeobjd $(KRBLIB) -lcull -lcomm -lcommlists -luti $(SECLIB) $(WINGRIDLIB) -ldb$(BDB_LIB_SUFFIX) $(DLLIB) $(SLIBS) $(LIBS)
|
|
|
|
spooledit.o: $(UTILBIN_DIR)/spooledit.c
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/spooledit.c
|
|
@@ -290,7 +290,7 @@ valid_jvmlib.o: $(UTILBIN_DIR)/valid_jv
|
|
$(CC) $(CFLAGS) -c $(UTILBIN_DIR)/valid_jvmlib.c
|
|
|
|
#---------------------------------------------------------------------
|
|
-AUTHUSER_ADD_LIBS = $(UTILIB) $(COMMLISTSLIB) $(DLLIB)
|
|
+AUTHUSER_ADD_LIBS = $(UTILIB) -lcommlists $(DLLIB)
|
|
|
|
authuser: authuser.o juti.o $(UTILIB) $(COMMLISTSLIB)
|
|
$(CC) -o authuser $(LFLAGS) authuser.o juti.o $(AUTHLIBS) $(AUTHUSER_ADD_LIBS) $(LIBS)
|