pkgsrc/lang/gcc/patches/patch-ac
tron 178cf5b627 - Add patches from NetBSD-current to fix build on i386 ELF systems.
- Install into "${LOCALBASE}/gcc-2.95.2" to avoid that e.g. "bsd.pkg.mk"
  picks up the new compiler by accident.
- Add a file "${LOCALBASE}/etc/gcc-2.95.2.mk" which makes it possible to
  use the new "gcc" like this:
  make MAKECONF=/usr/pkg/etc/gcc-2.95.2.mk
2000-09-15 23:58:47 +00:00

28 lines
1.1 KiB
Text

$NetBSD: patch-ac,v 1.1 2000/09/15 23:58:48 tron Exp $
--- ../gcc-2.95.2/gcc/config/i386/xm-netbsd.h.orig Sat Sep 16 00:17:42 2000
+++ ../gcc-2.95.2/gcc/config/i386/xm-netbsd.h Sat Sep 16 00:17:42 2000
@@ -0,0 +1,23 @@
+/* Configuration file for i386 hosts running NetBSD.
+ Copyright (C) 1999 Free Software Foundation, Inc.
+
+This file is part of GNU CC.
+
+GNU CC is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2, or (at your option)
+any later version.
+
+GNU CC is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with GNU CC; see the file COPYING. If not, write to
+the Free Software Foundation, 59 Temple Place - Suite 330,
+Boston, MA 02111-1307, USA. */
+
+#include <xm-netbsd.h>
+#include <i386/xm-i386.h>
+