95 lines
2.5 KiB
Text
95 lines
2.5 KiB
Text
$NetBSD: patch-ab,v 1.9 2006/04/04 14:45:45 jlam Exp $
|
|
|
|
--- sources/Makefile.orig 2006-04-01 00:34:38.000000000 -0500
|
|
+++ sources/Makefile
|
|
@@ -44,12 +44,12 @@ infodir = $(prefix)/info
|
|
# CC and CFLAGS set for gcc, but any ANSI-C compiler should work.
|
|
# For non-gcc compilers, simply set CFLAGS = -O (to start with)
|
|
#
|
|
-CC = gcc
|
|
-CFLAGS = -O2 -Wall -finline-functions
|
|
+#CC = gcc
|
|
+#CFLAGS = -O2 -Wall -finline-functions
|
|
|
|
-LFLAGS = # only sometimes needed; see below for examples
|
|
-CPPFLAGS = -I. # only sometimes needed; see below for examples
|
|
-BINDCMD = # only needed for EMX and DJGPP DOS extenders
|
|
+LFLAGS = ${XLDFLAGS}
|
|
+CPPFLAGS = -I. ${XCPPFLAGS}
|
|
+BINDCMD = echo
|
|
|
|
|
|
|
|
@@ -62,7 +62,7 @@ BINDCMD = # only needed
|
|
#
|
|
DEFINES = -DUNIX -DHAS_UNIX_X11
|
|
PREVIEWER = to_x11
|
|
-ALL_LIBS = -lX11 -lm # Maybe -lX instead of -lX11 is needed?
|
|
+ALL_LIBS = -lX11 -lm -lz -lpng -lpdf -ltiff -ljpeg
|
|
#
|
|
# Generic UNIX, no previewer
|
|
#
|
|
@@ -197,29 +197,29 @@ EX_OBJ =
|
|
EX_DEFS =
|
|
#
|
|
# PNG support (requires -lpng and -lz on the ALL_LIBS line)
|
|
-#EX_SRC = png.c to_png.c
|
|
-#EX_OBJ = png.o to_png.o
|
|
-#EX_DEFS= -DPNG
|
|
+EX_SRC = png.c to_png.c
|
|
+EX_OBJ = png.o to_png.o
|
|
+EX_DEFS= -DPNG
|
|
#
|
|
# TIFF support (requires -ltiff and possibly -lz on the ALL_LIBS line)
|
|
-#EX_SRC = to_tif.c
|
|
-#EX_OBJ = to_tif.o
|
|
-#EX_DEFS = -DTIF
|
|
+EX_SRC = to_tif.c
|
|
+EX_OBJ = to_tif.o
|
|
+EX_DEFS = -DTIF
|
|
#
|
|
# JPEG support (requires -ljpeg)
|
|
-#EX_SRC = to_jpg.c
|
|
-#EX_OBJ = to_jpg.o
|
|
-#EX_DEFS = -DJPG
|
|
+EX_SRC = to_jpg.c
|
|
+EX_OBJ = to_jpg.o
|
|
+EX_DEFS = -DJPG
|
|
#
|
|
# PDF support (requires -lpdf)
|
|
-#EX_SRC = to_pdf.c
|
|
-#EX_OBJ = to_pdf.o
|
|
-#EX_DEFS = -DUSEPDF
|
|
+EX_SRC = to_pdf.c
|
|
+EX_OBJ = to_pdf.o
|
|
+EX_DEFS = -DUSEPDF
|
|
#
|
|
# Include extras:
|
|
-# EX_SRC = to_pic.c to_pac.c
|
|
-# EX_OBJ = to_pic.o to_pac.o
|
|
-# EX_DEFS = -DPIC_PAC
|
|
+EX_SRC = to_pic.c to_pac.c
|
|
+EX_OBJ = to_pic.o to_pac.o
|
|
+EX_DEFS = -DPIC_PAC
|
|
#
|
|
#############################################################################
|
|
# No user-serviceable parts below!
|
|
@@ -332,15 +332,11 @@ TAGS:
|
|
install: install-bin install-info install-man
|
|
|
|
install-bin: $(PROGRAM)
|
|
- -$(STRIP) $(PROGRAM)
|
|
- $(CP) $(PROGRAM) $(bindir)
|
|
- $(CHMOD) 755 $(bindir)/$(PROGRAM)
|
|
+ ${BSD_INSTALL_PROGRAM} $(PROGRAM) $(bindir)
|
|
|
|
install-info: hp2xx.info
|
|
- $(CP) hp2xx.info $(infodir)
|
|
- $(CHMOD) 644 $(infodir)/hp2xx.info
|
|
+ ${BSD_INSTALL_MAN} hp2xx.info $(infodir)
|
|
|
|
install-man: ../doc/hp2xx.1
|
|
- $(CP) ../doc/hp2xx.1 $(man1dir)
|
|
- $(CHMOD) 644 $(man1dir)/hp2xx.1
|
|
+ ${BSD_INSTALL_MAN} ../doc/hp2xx.1 $(man1dir)
|
|
|