pkgsrc/net/rp-pppoe/patches/patch-aa
martin a8911c661d Update rp-pppoe to 3.8: various internal changes, some of them bogus
and reverted by patches, some of them were already present in (now
removed) patches; plus:

- Changed the names of commands from adsl-* to pppoe-* to more logically
  name the scripts.

- Make the userland pppoe daemon run as "nobody" if possible, once session
  has started.

- Make userland pppoe program somewhat safe if it is installed SUID or
  SGID.  Note that I still do *NOT* recommend a SUID/SGID pppoe.

- Fix long-standing bug in pppoe-server that passed arguments to pppd in the
  wrong order.
2006-11-01 15:17:13 +00:00

120 lines
6 KiB
Text

$NetBSD: patch-aa,v 1.11 2006/11/01 15:17:13 martin Exp $
--- src/Makefile.in.orig 2006-04-02 16:29:42.000000000 +0200
+++ src/Makefile.in 2006-11-01 12:32:04.000000000 +0100
@@ -61,6 +61,9 @@
CFLAGS= @CFLAGS@ $(LIC_INCDIR) $(DEFINES) $(LIC_DEFINE) $(PATHS) -Ilibevent
TARGETS=@TARGETS@
PPPOE_SERVER_LIBS=$(LIC_LIBDIR) $(LIC_LIB)
+.if ${OPSYS} == "DragonFly"
+PPPOE_SERVER_LIBS+= -lmd
+.endif
all: $(TARGETS)
@echo ""
@@ -87,9 +90,6 @@
ppp.o: ppp.c pppoe.h
@CC@ $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o ppp.o ppp.c
-md5.o: md5.c md5.h
- @CC@ $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o md5.o md5.c
-
pppoe-server.o: pppoe-server.c pppoe.h @PPPOE_SERVER_DEPS@
@CC@ $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o pppoe-server.o pppoe-server.c
@@ -147,7 +147,7 @@
$(install) -m 755 ../scripts/pppoe-setup $(RPM_INSTALL_ROOT)$(sbindir)
-mkdir -p $(RPM_INSTALL_ROOT)$(docdir)
$(install) -m 644 ../doc/CHANGES $(RPM_INSTALL_ROOT)$(docdir)
- $(install) -m 644 ../doc/KERNEL-MODE-PPPOE $(RPM_INSTALL_ROOT)$(docdir)
+# $(install) -m 644 ../doc/KERNEL-MODE-PPPOE $(RPM_INSTALL_ROOT)$(docdir)
$(install) -m 644 ../doc/HOW-TO-CONNECT $(RPM_INSTALL_ROOT)$(docdir)
$(install) -m 644 ../doc/LICENSE $(RPM_INSTALL_ROOT)$(docdir)
$(install) -m 644 ../README $(RPM_INSTALL_ROOT)$(docdir)
@@ -166,47 +166,47 @@
$(install) -m 644 ../man/pppoe-setup.8 $(RPM_INSTALL_ROOT)$(mandir)/man8
-mkdir -p $(RPM_INSTALL_ROOT)$(mandir)/man5
$(install) -m 644 ../man/pppoe.conf.5 $(RPM_INSTALL_ROOT)$(mandir)/man5
- -mkdir -p $(RPM_INSTALL_ROOT)/etc/ppp
- -mkdir -p $(RPM_INSTALL_ROOT)$(PLUGIN_DIR)
- -echo "# Directory created by rp-pppoe for kernel-mode plugin" > $(RPM_INSTALL_ROOT)$(PLUGIN_DIR)/README
- @if test -r rp-pppoe.so; then $(install) -m 755 rp-pppoe.so $(RPM_INSTALL_ROOT)$(PLUGIN_DIR); fi
- @for i in pppoe.conf firewall-standalone firewall-masq ; do \
- if [ ! -f $(RPM_INSTALL_ROOT)/etc/ppp/$$i ] ; then \
- $(install) -m 644 ../configs/$$i $(RPM_INSTALL_ROOT)/etc/ppp ; \
- else \
- echo "NOT overwriting existing $(RPM_INSTALL_ROOT)/etc/ppp/$$i" ;\
- $(install) -m 644 ../configs/$$i $(RPM_INSTALL_ROOT)/etc/ppp/$$i-$(VERSION) ;\
- fi ;\
- done
- @if [ ! -f $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS) ] ; then \
- $(install) -m 644 ../configs/pppoe-server-options $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS) ; \
- else \
- echo "NOT overwriting existing $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS)"; \
- $(install) -m 644 ../configs/pppoe-server-options $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS)-example ; \
- fi
- @if [ -f /etc/redhat-release ] ; then \
- echo "Looks like a Red Hat system; installing $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe" ; \
- mkdir -p $(RPM_INSTALL_ROOT)/etc/rc.d/init.d ;\
- $(install) -m 755 ../scripts/pppoe-init $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe ; \
- fi
- @if [ -f /etc/turbolinux-release ] ; then \
- echo "Looks like a TurboLinux system; installing $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe" ; \
- mkdir -p $(RPM_INSTALL_ROOT)/etc/rc.d/init.d ;\
- $(install) -m 755 ../scripts/pppoe-init-turbolinux $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe ; \
- fi
- @if [ -f /etc/SuSE-release ] ; then \
- echo "Looks like a SuSE Linux system; installing $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe" ; \
- mkdir -p $(RPM_INSTALL_ROOT)/etc/rc.d/init.d ;\
- $(install) -m 755 ../scripts/pppoe-init-suse $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe ; \
- fi
+# -mkdir -p $(RPM_INSTALL_ROOT)/etc/ppp
+# -mkdir -p $(RPM_INSTALL_ROOT)$(PLUGIN_DIR)
+# -echo "# Directory created by rp-pppoe for kernel-mode plugin" > $(RPM_INSTALL_ROOT)$(PLUGIN_DIR)/README
+# @if test -r rp-pppoe.so; then $(install) -m 755 rp-pppoe.so $(RPM_INSTALL_ROOT)$(PLUGIN_DIR); fi
+# @for i in pppoe.conf firewall-standalone firewall-masq ; do \
+# if [ ! -f $(RPM_INSTALL_ROOT)/etc/ppp/$$i ] ; then \
+# $(install) -m 644 ../configs/$$i $(RPM_INSTALL_ROOT)/etc/ppp ; \
+# else \
+# echo "NOT overwriting existing $(RPM_INSTALL_ROOT)/etc/ppp/$$i" ;\
+# $(install) -m 644 ../configs/$$i $(RPM_INSTALL_ROOT)/etc/ppp/$$i-$(VERSION) ;\
+# fi ;\
+# done
+# @if [ ! -f $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS) ] ; then \
+# $(install) -m 644 ../configs/pppoe-server-options $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS) ; \
+# else \
+# echo "NOT overwriting existing $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS)"; \
+# $(install) -m 644 ../configs/pppoe-server-options $(RPM_INSTALL_ROOT)$(PPPOESERVER_PPPD_OPTIONS)-example ; \
+# fi
+# @if [ -f /etc/redhat-release ] ; then \
+# echo "Looks like a Red Hat system; installing $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe" ; \
+# mkdir -p $(RPM_INSTALL_ROOT)/etc/rc.d/init.d ;\
+# $(install) -m 755 ../scripts/pppoe-init $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe ; \
+# fi
+# @if [ -f /etc/turbolinux-release ] ; then \
+# echo "Looks like a TurboLinux system; installing $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe" ; \
+# mkdir -p $(RPM_INSTALL_ROOT)/etc/rc.d/init.d ;\
+# $(install) -m 755 ../scripts/pppoe-init-turbolinux $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe ; \
+# fi
+# @if [ -f /etc/SuSE-release ] ; then \
+# echo "Looks like a SuSE Linux system; installing $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe" ; \
+# mkdir -p $(RPM_INSTALL_ROOT)/etc/rc.d/init.d ;\
+# $(install) -m 755 ../scripts/pppoe-init-suse $(RPM_INSTALL_ROOT)/etc/rc.d/init.d/pppoe ; \
+# fi
# L2TP
- @if [ -f l2tp/handlers/sync-pppd.so ] ; then \
- mkdir -p $(RPM_INSTALL_ROOT)/usr/lib/l2tp/plugins ; \
- $(install) -m 755 l2tp/handlers/sync-pppd.so $(RPM_INSTALL_ROOT)/usr/lib/l2tp/plugins ; \
- mkdir -p $(RPM_INSTALL_ROOT)/etc/l2tp ; \
- $(install) -m 600 l2tp/l2tp.conf $(RPM_INSTALL_ROOT)/etc/l2tp/l2tp.conf.example ; \
- fi
+# @if [ -f l2tp/handlers/sync-pppd.so ] ; then \
+# mkdir -p $(RPM_INSTALL_ROOT)/usr/lib/l2tp/plugins ; \
+# $(install) -m 755 l2tp/handlers/sync-pppd.so $(RPM_INSTALL_ROOT)/usr/lib/l2tp/plugins ; \
+# mkdir -p $(RPM_INSTALL_ROOT)/etc/l2tp ; \
+# $(install) -m 600 l2tp/l2tp.conf $(RPM_INSTALL_ROOT)/etc/l2tp/l2tp.conf.example ; \
+# fi
@echo ""
@echo "Type 'pppoe-setup' to configure the software."