pkgsrc/audio/xmms-mad/patches/patch-ac
wiz e38d9d3ce7 Update to 0.5.7:
2004-05-16  Sam Clegg

	* Version 0.5.7

	* Implement simple config dialog.

	* When fast playtime calculation is enabled, dedode the first
	  10 frames only.

2004-01-24  Sam Clegg

	* decoder.c: better xing bitrate calculation.

2003-12-28  Sam Clegg

	* Version 0.5.6

	* configure.ac: don't depend on pkgconfig files from
	libmad and libid3tag that aren't shipped by upstream

	* decoder.c xmms-mad.[ch]: fix xing header usage. added
	use_xing configuration option to disable it.
2006-08-07 23:46:23 +00:00

25 lines
632 B
Text

$NetBSD: patch-ac,v 1.3 2006/08/07 23:46:23 wiz Exp $
--- src/input.c.orig 2004-05-16 16:24:04.000000000 +0000
+++ src/input.c
@@ -28,6 +28,10 @@
#include <sys/types.h>
#endif /* HAVE_SYS_TYPES_H */
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+
#ifdef HAVE_SYS_SOCKET_H
#include <sys/socket.h>
#endif /* HAVE_SYS_SOCKET_H */
@@ -451,6 +455,9 @@ input_read_tag (struct mad_info_t *info)
if (title_input->genre) g_free (title_input->genre);
if (title_input->comment) g_free (title_input->comment);
g_free (title_input);
+
+ id3_file_close (info->id3file);
+ info->id3file = NULL;
}
/**