(contains security fix for CVE-2011-0728). What's changed in loggerhead? ============================= 1.18.1 [24Mar2011] ------------------ - Fix escaping of filenames in revision views. (William Grant, #740142) - Add missing import to loggerhead.trace, allowing start-loggerhead to run when a log.roll config option is set. (Max Kanat-Alexander, #673999) 1.18 [10Nov2010] ---------------- - Syntax highlighting is no longer applied for files greater than 512K, reducing codebrowse.launchpad.net overloading. (Max Kanat-Alexander, #513044) - Documentation added in the docs directory. README simplified accordingly. (Tres Seaver). - Show svn/git/hg revision ids in loggerhead revision view. (Jelmer Vernooij) - Fix .bzr/smart access to branches in shared repos. (You also need a version of bzr with bug #348308 fixed.) (Andrew Bennetts) - Support FastCGI, SCGI and AJP using flup. (Denis Martinez) - Repository.get_revision_inventory() was removed in bzr 2.2; use Repository.get_inventory() instead. (Matt Nordhoff, #528194) - Ignore readonly+ prefix when checking if Loggerhead is serving a local location. (Reported by Tres Seaver.) (Matt Nordhoff) - Set Cache-Control and Expires headers on static pages. (John Arbash Meinel) - Generate relative links where possible (everywhere but HTTP redirects and feed IDs). (Michael Hudson, Matt Nordhoff) - Fix bad redirect when visiting "/download" or "/download/". (Matt Nordhoff, #247992)
21 lines
746 B
Text
21 lines
746 B
Text
$NetBSD: patch-aa,v 1.3 2011/03/26 08:02:38 obache Exp $
|
|
|
|
--- setup.py.orig 2011-03-24 23:14:27.000000000 +0000
|
|
+++ setup.py
|
|
@@ -18,6 +18,7 @@
|
|
|
|
"""Loggerhead is a web viewer for projects in bazaar"""
|
|
|
|
+import os
|
|
from distutils.core import setup
|
|
|
|
import loggerhead
|
|
@@ -64,7 +65,7 @@ setup(
|
|
"static/javascript/yui/build/yui-base/*",
|
|
"static/images/*"]},
|
|
data_files = [
|
|
- ('share/man/man1', ['start-loggerhead.1',
|
|
+ (os.getenv('PKGMANDIR', 'share/man') + '/man1', ['start-loggerhead.1',
|
|
'stop-loggerhead.1',
|
|
'serve-branches.1']),
|
|
('share/doc/loggerhead', ['loggerhead.conf.example']),
|