19f99199a4
as part of the configure options. A pth with this option enabled provides some semblance of pre-emptive threads - enough for things like xmms and knode to actually work. Add the necessary glue to pthread.buildlink.mk and appropriate CONFLICT into pth. It is hoped that the pkgs that currently use -D_POSIX_THREAD_SYSCALL_SOFT=1 will be tested against pth-syscall and changed to use it. The goal is to be able to add --enable-syscall-hard to devel/pth and retire pth-syscall. Baby steps...
23 lines
752 B
Text
23 lines
752 B
Text
$NetBSD: patch-af,v 1.1 2002/05/29 08:20:01 skrll Exp $
|
|
|
|
--- pth.h.in.orig Sat Mar 24 14:49:49 2001
|
|
+++ pth.h.in
|
|
@@ -44,6 +44,7 @@
|
|
#include <sys/socket.h> /* for sockaddr */
|
|
#include <sys/signal.h> /* for sigset_t */
|
|
@EXTRA_INCLUDE_SYS_SELECT_H@
|
|
+@EXTRA_INCLUDE_SYS_RESOURCE_H@
|
|
|
|
/* fallbacks for essential typedefs */
|
|
#ifndef _PTHREAD_PRIVATE
|
|
@@ -499,7 +500,10 @@
|
|
extern ssize_t pth_pread(int, void *, size_t, off_t);
|
|
extern ssize_t pth_pwrite(int, const void *, size_t, off_t);
|
|
|
|
+ /* additional replacement functions */
|
|
+extern pid_t pth_wait4(pid_t, int *, int, struct rusage *);
|
|
END_DECLARATION
|
|
+
|
|
|
|
/* soft system call mapping support */
|
|
#if PTH_SYSCALL_SOFT && !defined(_PTH_PRIVATE)
|