<stdlib.h>, remove local declarations of things that are declared standard headers, and explicilty declare a function to return int. Bump PKGREVISION to 1. Both the old and new patch-aa do the same thing, despite looking so different. The new one was produced by mkpatches.
36 lines
635 B
Text
36 lines
635 B
Text
$NetBSD: patch-aa,v 1.3 2011/08/13 09:09:00 apb Exp $
|
|
|
|
--- Makefile.orig 1995-07-01 15:33:24.000000000 +0000
|
|
+++ Makefile
|
|
@@ -1,25 +1,10 @@
|
|
-CFLAGS =-O
|
|
-LDFLAGS =-s
|
|
-
|
|
-INSTX =install -m 0755 -s
|
|
-INSTD =install -m 0644
|
|
-
|
|
-DEST=
|
|
-
|
|
-MI =$(DEST)/usr/
|
|
-MD =$(DEST)/usr/
|
|
-
|
|
-M1X =1
|
|
-
|
|
-BIND =$(MD)bin/
|
|
-MANI =$(MI)man
|
|
+PROG= team
|
|
|
|
-MANI1 =$(MANI)$(M1X)/
|
|
+BINDIR= ${PREFIX}/bin
|
|
+MANDIR= ${PREFIX}/man
|
|
|
|
-all: team
|
|
+MANINSTALL= catinstall maninstall
|
|
|
|
-clean::
|
|
- rm -f team team.o
|
|
+CFLAGS+= -DHAVE_PARAM_H -DHAVE_WAIT_H
|
|
|
|
-$(BIND)team: team; $(INSTX) $? $@
|
|
-$(MANI1)team.$(M1X): team.1; $(INSTD) $? $@
|
|
+.include <bsd.prog.mk>
|