75 lines
2.7 KiB
Text
75 lines
2.7 KiB
Text
$NetBSD: patch-ab,v 1.8 2011/07/15 08:47:22 asau Exp $
|
|
|
|
Enable building the shared libstdc++
|
|
|
|
also make the sersion number the same as the one we ship with netbsd-1.6 as
|
|
we use the same sources.
|
|
|
|
--- libstdc++/Makefile.in.orig 2011-07-12 16:44:41.000000000 +0400
|
|
+++ libstdc++/Makefile.in 2011-07-12 16:56:07.000000000 +0400
|
|
@@ -14,7 +14,7 @@
|
|
# along with this library; see the file COPYING. If not, write to the Free
|
|
# Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
|
|
|
-VERSION = 2.10.0nb1
|
|
+VERSION = 4.0
|
|
INTERFACE = 3
|
|
|
|
gxx_include_dir=${includedir}/g++
|
|
@@ -43,7 +43,7 @@
|
|
|
|
STAMP = bigstmp
|
|
|
|
-LIBS = $(ARLIB) $(ARLINK)
|
|
+LIBS = $(ARLIB) $(ARLINK) $(SHLIB) $(SHLINK)
|
|
|
|
#### package, host, target, and site dependent Makefile fragments come in here.
|
|
##
|
|
@@ -263,34 +263,34 @@
|
|
if [ -z "$(MULTISUBDIR)" ]; then \
|
|
cd $(srcdir); \
|
|
for FILE in $(HEADERS); do \
|
|
- rm -f $(gxx_include_dir)/$$FILE ; \
|
|
+ rm -f $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
if [ -f stl/$$FILE ]; then \
|
|
- $(INSTALL_DATA) stl/$$FILE $(gxx_include_dir)/$$FILE ; \
|
|
+ $(INSTALL_DATA) stl/$$FILE $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
else \
|
|
- $(INSTALL_DATA) $$FILE $(gxx_include_dir)/$$FILE ; \
|
|
+ $(INSTALL_DATA) $$FILE $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
fi ; \
|
|
- chmod a-x $(gxx_include_dir)/$$FILE ; \
|
|
+ chmod a-x $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
done ; \
|
|
for FILE in *.h std/*.h std/*.cc std/*.tcc; do \
|
|
- rm -f $(gxx_include_dir)/$$FILE ; \
|
|
- $(INSTALL_DATA) $$FILE $(gxx_include_dir)/$$FILE ; \
|
|
- chmod a-x $(gxx_include_dir)/$$FILE ; \
|
|
+ rm -f $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
+ $(INSTALL_DATA) $$FILE $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
+ chmod a-x $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
done ; \
|
|
cd stl; \
|
|
for FILE in *.h; do \
|
|
- rm -f $(gxx_include_dir)/$$FILE ; \
|
|
- $(INSTALL_DATA) $$FILE $(gxx_include_dir)/$$FILE ; \
|
|
- chmod a-x $(gxx_include_dir)/$$FILE ; \
|
|
+ rm -f $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
+ $(INSTALL_DATA) $$FILE $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
+ chmod a-x $(DESTDIR)$(gxx_include_dir)/$$FILE ; \
|
|
done ; \
|
|
else true ; \
|
|
fi
|
|
rootme=`pwd`/ ; export rootme ; \
|
|
if [ x$(enable_version_specific_runtime_libs) != xyes ]; then \
|
|
- INSTALLDIR=$(libdir); \
|
|
+ INSTALLDIR=$(DESTDIR)$(libdir); \
|
|
else \
|
|
- INSTALLDIR=$(libsubdir); \
|
|
+ INSTALLDIR=$(DESTDIR)$(libsubdir); \
|
|
fi; \
|
|
- INSTALLLINKDIR=$(libsubdir); \
|
|
+ INSTALLLINKDIR=$(DESTDIR)$(libsubdir); \
|
|
if [ $${INSTALLLINKDIR}$(MULTISUBDIR) = $${INSTALLDIR}$(MULTISUBDIR) ]; then \
|
|
RELINSTALLDIR=; \
|
|
elif [ x$(MULTISUBDIR) = x ]; then \
|