2a13ce7558
* Language ** Generalized client values in server code ** Injections into client sections * Tools ** Added eliom-destillery for generating project scaffolds ** Support Eliom interface files (.eliomi) in eliomc, eliomdep ** eliomdep: Generate dependencies between eliom-modules ** eliomc: infer only with option -infer, drop option -noinfer ** eliomc: Basic support for -i on eliom-files ** eliom{c,dep,opt},js_of_eliom: -dump to output the intermediate code ** eliomc,js_of_eliom: always open Eliom_pervasives in eliom files * API ** Eliom_pervasives.server_function to easily access the from the client ** Get current state of a scope ** Module to access values of Eliom references in external states (Eliom_state.Ext) ** Scope names are now named scope hierarchies ** Iterate the scope hierarchy (group > session > client > request) ** Adding Eliom_parameter.(type_checker, neopt) ** Add functions to insert html5 in atom feeds ** Eliom_tools.{F,D}.html to ease creation of head-tag ** Eliom_tools.wrap_handler as an easy alernative to Eliom_registration.Customize ** Test for initial request of a client on the server * Changed server behaviour ** Eliom_state.discard_everything now also discards request state ** Don't send nodes as data when they are part of the document * Changed client behaviour ** Show progress cursor during navigation with change_page ** Improved error messages ** Fail on the client when a [server_function] or call_caml_service fails on the server * Bugfixes ** Allow % for injections directly after parentheses * Support dropped for ** Xhtml ** OCamlDuce ** Eliom_compatibility_2_1 * A myriade of bugfixes
18 lines
821 B
Text
18 lines
821 B
Text
$NetBSD: patch-src_Makefile,v 1.2 2012/12/15 16:18:42 jaapb Exp $
|
|
|
|
Use correct BSD installation tools
|
|
--- src/Makefile.orig 2012-12-13 16:16:17.000000000 +0000
|
|
+++ src/Makefile
|
|
@@ -60,9 +60,9 @@ install: install.META install.man
|
|
${MAKE} -C tools install
|
|
|
|
install.man: install.META
|
|
- $(INSTALL) -m 755 -d $(TEMPROOT)$(MANDIR)/man1
|
|
- $(INSTALL) -m 755 files/eliomc.1 $(TEMPROOT)$(MANDIR)/man1
|
|
- $(INSTALL) -m 755 files/eliom-destillery.1 $(TEMPROOT)$(MANDIR)/man1
|
|
+ $(BSD_INSTALL_MAN_DIR) -d $(TEMPROOT)$(MANDIR)/man1
|
|
+ $(BSD_INSTALL_MAN) files/eliomc.1 $(TEMPROOT)$(MANDIR)/man1
|
|
+ $(BSD_INSTALL_MAN) files/eliom-destillery.1 $(TEMPROOT)$(MANDIR)/man1
|
|
ln -sf eliomc.1 $(TEMPROOT)$(MANDIR)/man1/js_of_eliom.1
|
|
ln -sf eliomc.1 $(TEMPROOT)$(MANDIR)/man1/eliomopt.1
|
|
ln -sf eliomc.1 $(TEMPROOT)$(MANDIR)/man1/eliomcp.1
|