pkgsrc/devel/py-setuptools/patches/patch-setup.py
wiz 57f28de1f5 Update to 0.7.7. Simplify. Set LICENSE. Allow python-3.x.
-----
0.7.7
-----

* Distribute #375: Repair AttributeError created in last release (redo).
* Issue #30: Added test for get_cache_path.

-----
0.7.6
-----

* Distribute #375: Repair AttributeError created in last release.

-----
0.7.5
-----

* Issue #21: Restore Python 2.4 compatibility in ``test_easy_install``.
* Distribute #375: Merged additional warning from Distribute 0.6.46.
* Now honor the environment variable
  ``SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT`` in addition to the now
  deprecated ``DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT``.

-----
0.7.4
-----

* Issue #20: Fix comparison of parsed SVN version on Python 3.

-----
0.7.3
-----

* Issue #1: Disable installation of Windows-specific files on non-Windows systems.
* Use new sysconfig module with Python 2.7 or >=3.2.

-----
0.7.2
-----

* Issue #14: Use markerlib when the `parser` module is not available.
* Issue #10: ``ez_setup.py`` now uses HTTPS to download setuptools from PyPI.

-----
0.7.1
-----

* Fix NameError (Issue #3) again - broken in bad merge.

---
0.7
---

* Merged Setuptools and Distribute. See docs/merge.txt for details.

Added several features that were slated for setuptools 0.6c12:

* Index URL now defaults to HTTPS.
* Added experimental environment marker support. Now clients may designate a
  PEP-426 environment marker for "extra" dependencies. Setuptools uses this
  feature in ``setup.py`` for optional SSL and certificate validation support
  on older platforms. Based on Distutils-SIG discussions, the syntax is
  somewhat tentative. There should probably be a PEP with a firmer spec before
  the feature should be considered suitable for use.
* Added support for SSL certificate validation when installing packages from
  an HTTPS service.

-----
0.7b4
-----

* Issue #3: Fixed NameError in SSL support.
2013-07-04 06:43:12 +00:00

16 lines
593 B
Python

$NetBSD: patch-setup.py,v 1.1 2013/07/04 06:43:13 wiz Exp $
Do not install easy_install without python version suffix to allow
parallel installation of this package for multiple python versions.
--- setup.py.orig 2013-07-02 15:45:46.000000000 +0000
+++ setup.py
@@ -54,7 +54,7 @@ from setuptools.command.test import test
scripts = []
-console_scripts = ["easy_install = setuptools.command.easy_install:main"]
+console_scripts = []
# Gentoo distributions manage the python-version-specific scripts themselves,
# so they define an environment variable to suppress the creation of the