pkgsrc/print/ja-vflib-lib/patches/patch-ac
jlam e2afa97f51 Merge changes in packages from the buildlink2 branch that have
buildlink2.mk files back into the main trunk.  This provides sufficient
buildlink2 infrastructure to start merging other packages from the
buildlink2 branch that have already been converted to use the buildlink2
framework.
2002-08-25 18:38:05 +00:00

33 lines
1.1 KiB
Text

$NetBSD: patch-ac,v 1.2 2002/08/25 18:39:45 jlam Exp $
--- src/Makefile.in.orig Tue Oct 27 02:33:17 1998
+++ src/Makefile.in
@@ -61,7 +61,7 @@
# VFlib
$(VFLIB): $(CORE_OBJ) $(DRV_OBJ)
$(LIBTOOL) --mode=link \
- $(CC) -o $(VFLIB) $(CORE_OBJ) $(DRV_OBJ) \
+ $(CC) $(LDFLAGS) -o $(VFLIB) $(CORE_OBJ) $(DRV_OBJ) \
-version-info @version_info@ -rpath $(libdir) \
$(EXT_LIBRARY)
@@ -183,13 +183,13 @@
# Installing
install:
- $(LIBTOOL) $(CP) $(VFLIB) $(libdir)/$(VFLIB)
+ $(LIBTOOL) $(BSD_INSTALL_DATA) $(VFLIB) $(libdir)/$(VFLIB)
$(LIBTOOL) -n --finish $(libdir)
- $(CP) VF.h $(includedir)/VF.h
- $(CP) VF.h $(runtimedir)/VF.h
- $(LIBTOOL) $(CP) ttindex $(bindir)/ttindex
- $(LIBTOOL) $(CP) bdfindex $(bindir)/bdfindex
- $(LIBTOOL) $(CP) bdfindex $(bindir)/fwindex
+ $(BSD_INSTALL_DATA) VF.h $(includedir)/VF.h
+ $(BSD_INSTALL_DATA) VF.h $(runtimedir)/VF.h
+ $(LIBTOOL) $(BSD_INSTALL_PROGRAM) ttindex $(bindir)/ttindex
+ $(LIBTOOL) $(BSD_INSTALL_PROGRAM) bdfindex $(bindir)/bdfindex
+ $(LIBTOOL) $(BSD_INSTALL_PROGRAM) bdfindex $(bindir)/fwindex
uninstall:
-$(LIBTOOL) $(RM) $(libdir)/$(VFLIB)
-$(RM) $(includedir)/VF.h