pkgsrc/math/pari/patches/patch-al
adam cae12cd501 Changes 2.1.6:
Fixed
- src/kernel/sparcv8/MakeVar.SH missing from MANIFEST (hence from tarball)
- stack corruption in matsnf() [ when GC occurs ]
- incorrect result in gaffsg(s < 0, t_PADIC)
- [hi-res plot: X-Windows] rescaling bug
- [ix86 + gcc]: fix "invalid preprocessing token" Warning
- removed hack in buchall()  [ function called through unappropriate
  type (in init mode) to avoid inserting irrelevant arguments ]. Caused
  some compiler to produce incorrect code (SEGV).
- typo in isabsolutepol(): SEGV in factorff for some t_POLs
  defined over the prime field
- inconsistent error message when starting 'gp -p 436273000'
- Configure support for GNU/Hurd
2005-09-08 08:39:59 +00:00

34 lines
1.2 KiB
Text

$NetBSD: patch-al,v 1.2 2005/09/08 08:39:59 adam Exp $
--- src/kernel/sparcv8/Makefile.SH.orig 2003-04-25 19:08:14.000000000 +0000
+++ src/kernel/sparcv8/Makefile.SH
@@ -5,7 +5,7 @@
# that can (resp. cannot) be inline.
# Problem: "divll" uses "overflow", so kernel2.o is not the same when
# compiled with gcc or with cc. We should try to find a workaround.
-# For NextStep or Linux
+# For NextStep, Linux, or NetBSD
# We don't accept "asm inline" since it does not work (Ptitboul)
if test "$gnuas" = "yes"; then do_cpp=yes; fi
@@ -37,14 +37,14 @@ fi
cat >> $file << EOT
pariinl.h: $level0 $level1
cat $level0 $level1 > \$@
-kernel.o: $kernel1
- \$(AS) \$(ASFLAGS) -o \$@ $kernel1
-kernel2.o: $kernel2
- \$(AS) \$(ASFLAGS) -o \$@ $kernel2
+kernel\$(_O): $kernel1
+ \$(CC) -c \$(CFLAGS) \$(CPPFLAGS) -o \$@ $kernel1
+kernel2\$(_O): $kernel2
+ \$(CC) -c \$(CFLAGS) \$(CPPFLAGS) -o \$@ $kernel2
# Level 1 kernel is the generic one
-mp.o: .headers $src/kernel/none/mp.c
+mp\$(_O): .headers $src/kernel/none/mp.c
\$(CC) -c \$(CFLAGS) \$(CPPFLAGS) -o \$@ $src/kernel/none/mp.c
-mpinl.o: .headers $level1
+mpinl\$(_O): .headers $level1
\$(CC) -c \$(CFLAGS) \$(CPPFLAGS) -o \$@ $src/kernel/none/level1.c
EOT