pkgsrc/wm/windowmaker/patches/patch-ab
wiz 8e258a060c Update to 0.65.0. Extract of changes:
Bug fixes for GNOME interaction; fixes for window positions/states after
wm crashes; removed single appicon stuff; fixed race conditions on signal
handlers; SIGINT will gently exit, SIGTERM will not be handled; better alpha
handling in some cases; MouseButton handling done differently (don't bind
Button to Action, but Action to Button); made "Keep on Top" in the dock/clip
menu a checked menu entry.
Please note: There was a bug in XPM saving -- please delete your icons in
~/GNUstep/.AppInfo/WindowMaker, they will be recreated on the next start
of the corresponding programs.
2001-05-22 10:42:13 +00:00

39 lines
918 B
Text

$NetBSD: patch-ab,v 1.3 2001/05/22 10:42:13 wiz Exp $
--- configure.in.orig Sun Apr 29 23:21:39 2001
+++ configure.in
@@ -223,29 +223,11 @@
supported_locales="cs de es et fr gl it ja ko nl no pt ru sv tr fi hr el pl ro da zh_TW.Big5 zh_CN sk bg hu"
supported_wprefs_locales="pt hr fr ko ja cs zh_TW.Big5 es zh_CN fi it ru de bg hu sk"
-for lang in $LINGUAS; do
- ok=0
- for l in $supported_locales; do
- if test "$l" = "$lang"; then
- ok=1
- break
- fi
- done
- if test "$ok" = 1; then
- MOFILES="$MOFILES $lang.mo"
- else
- echo "Locale $lang is not supported."
- fi
- ok=0
- for l in $supported_wprefs_locales; do
- if test "$l" = "$lang"; then
- ok=1
- break
- fi
- done
- if test "$ok" = 1; then
- WPMOFILES="$WPMOFILES $lang.mo"
- fi
+for lang in $supported_locales; do
+ MOFILES="$MOFILES $lang.mo"
+done
+for lang in $supported_wprefs_locales; do
+ WPMOFILES="$WPMOFILES $lang.mo"
done