fe09ce1470
Changelog: Version 4.46, 2011.11.04, urgency: LOW: * New features - Added Unix socket support (e.g. "connect = /var/run/stunnel/socket"). - Added "verify = 4" mode to ignore CA chain and only verify peer certificate. - Removed the limit of 16 IP addresses for a single 'connect' option. - Removed the limit of 256 stunnel.conf sections in PTHREAD threading model. It is still not possible have more than 63 sections on WIN32 platform. http://msdn.microsoft.com/en-us/library/windows/desktop/ms740141(v=vs.85).aspx * Optimizations - Reduced per-connection memory usage. - Performed a major refactoring of internal data structures. Extensive internal testing was performed, but some regression bugs are expected. * Bugfixes - Fixed WIN32 compilation with Mingw32. - Fixed non-blocking API emulation layer in UCONTEXT threading model. - Fixed signal handling in UCONTEXT threading model.
24 lines
782 B
Text
24 lines
782 B
Text
$NetBSD: patch-aa,v 1.25 2011/11/10 21:01:39 ryoon Exp $
|
|
|
|
Install configuration files into examples directory.
|
|
|
|
--- tools/Makefile.in.orig 2011-10-27 14:53:32.000000000 +0000
|
|
+++ tools/Makefile.in
|
|
@@ -196,7 +196,7 @@ top_srcdir = @top_srcdir@
|
|
EXTRA_DIST = ca.html ca.pl importCA.html importCA.sh script.sh \
|
|
stunnel.spec stunnel.cnf stunnel.nsi stunnel.license stunnel.conf
|
|
|
|
-confdir = $(sysconfdir)/stunnel
|
|
+confdir = $(datadir)/examples/stunnel
|
|
conf_DATA = stunnel.conf-sample
|
|
examplesdir = $(docdir)/examples
|
|
examples_DATA = ca.html ca.pl importCA.html importCA.sh script.sh \
|
|
@@ -377,7 +377,7 @@ info: info-am
|
|
|
|
info-am:
|
|
|
|
-install-data-am: install-confDATA install-data-local \
|
|
+install-data-am: install-confDATA \
|
|
install-examplesDATA
|
|
|
|
install-dvi: install-dvi-am
|