* Fix5010 Line intersection non fatal error * Fix2992 Use native Separators in Filename-edit-widget * Fix4633 'Save as...DXF' does not add file extension * Fix4412 Ftools: Input layers are not presented in alphabetical order * Fix4326 Use project title as default filename in Save and Save as dialogs * Fix4623 GPS plugin: 'Save as...' does not add file extension * Fix4652 Remove "unsynced" EPSG CRS that are not listed in GDAL * Fix4625 Enable wait cursor when WMS search is ongoing * Fix3845 Add support for modulo operator (%) in rule based rendering * Fix4193 GRASS Rasters are not drawn with user-defined style * Fix4557 Fix crash when project is not yet saved * Fix4315 'Stretch Histogram to full dataset' toolbar button does not work with GRASS rasters * Fix4632 More precise composer map rotation * Fix4664 Fix label orientation with line dependent position * Fix2435 Fix Query builder from layer properties when layer name in cyrrilic * Fix4684 Skip attribute values with invalid variant type * Fix4549 Update QgsGenericProjectionSelector bindings * Fix4129 GDAL provider: add statusChanged signal and fix debugging output * Fix4379 If set 'prompt for CRS', CRS is asked when creating new shapefile layer * Fix4694 Hourglass not shown when classifying * Fix4478 Actions using %% do not work from identify results * Fix4646 Editing of table of attributes goes Wild * Fix3963 Crash when applying a graduated vector style * Fix3185,4689 Gps Tools: Allow user to add new ports * Fix4402 QGIS crashes displaying overview if diagrams are used * Fix4371 Identify tool does not work with reprojected WMS layers * Fix4305 Query builder: added ' ' around numeric fields (wrong) * Fix4217 Allow up to 5 decimal places for width/size Scale Field * Fix4452 Support for cyrillic symbols in raster metadata * Fix4558 Enhancements in OGR Provider * Fix3201 Show warning when user tried to create field 'shape' in shapefile
70 lines
2.4 KiB
Text
70 lines
2.4 KiB
Text
$NetBSD: patch-CMakeLists.txt,v 1.2 2012/02/26 23:19:02 adam Exp $
|
|
|
|
Avoid application bundle on Mac OS X.
|
|
|
|
--- CMakeLists.txt.orig 2012-02-22 20:48:14.000000000 +0000
|
|
+++ CMakeLists.txt
|
|
@@ -5,11 +5,7 @@ SET(COMPLETE_VERSION ${CPACK_PACKAGE_VER
|
|
SET(RELEASE_NAME "Wroclaw")
|
|
SET(PROJECT_VERSION ${COMPLETE_VERSION})
|
|
PROJECT(qgis${PROJECT_VERSION})
|
|
-IF (APPLE)
|
|
- SET(QGIS_APP_NAME "QGIS")
|
|
-ELSE (APPLE)
|
|
- SET(QGIS_APP_NAME "qgis")
|
|
-ENDIF (APPLE)
|
|
+SET(QGIS_APP_NAME "qgis")
|
|
|
|
# Note the version no is Mmmpp for Major/minor/patch, 0-padded, thus '10100' for 1.1.0
|
|
MATH(EXPR QGIS_VERSION_INT "${CPACK_PACKAGE_VERSION_MAJOR}*10000+${CPACK_PACKAGE_VERSION_MINOR}*100+${CPACK_PACKAGE_VERSION_PATCH}")
|
|
@@ -286,10 +282,7 @@ ELSE (WIN32)
|
|
|
|
IF (APPLE)
|
|
# for Mac OS X, everything is put inside an application bundle
|
|
- SET (QGIS_MACAPP_PREFIX ${CMAKE_INSTALL_PREFIX}/${QGIS_APP_NAME}.app/Contents)
|
|
- SET (CMAKE_INSTALL_PREFIX ${QGIS_MACAPP_PREFIX}/MacOS)
|
|
# path for library references
|
|
- SET (CMAKE_INSTALL_NAME_DIR @executable_path/lib)
|
|
# 4 bundling levels, each includes previous
|
|
# 0 nothing
|
|
# 1 Qt frameworks
|
|
@@ -307,18 +300,16 @@ ELSE (WIN32)
|
|
|
|
SET (DEFAULT_BIN_SUBDIR bin)
|
|
SET (QGIS_BIN_SUBDIR_REV ..)
|
|
- SET (DEFAULT_CGIBIN_SUBDIR fcgi-bin)
|
|
+ SET (DEFAULT_CGIBIN_SUBDIR bin)
|
|
SET (QGIS_CGIBIN_SUBDIR_REV ..)
|
|
SET (DEFAULT_LIB_SUBDIR lib)
|
|
SET (QGIS_LIB_SUBDIR_REV ..)
|
|
- SET (QGIS_FW_SUBDIR ../Frameworks)
|
|
- SET (QGIS_FW_SUBDIR_REV ../MacOS)
|
|
- SET (DEFAULT_DATA_SUBDIR ../Resources)
|
|
- SET (QGIS_DATA_SUBDIR_REV ../MacOS)
|
|
+ SET (QGIS_DATA_SUBDIR_REV ../..)
|
|
SET (DEFAULT_LIBEXEC_SUBDIR lib/qgis)
|
|
SET (QGIS_LIBEXEC_SUBDIR_REV ../..)
|
|
- SET (DEFAULT_PLUGIN_SUBDIR ../PlugIns/qgis)
|
|
- SET (QGIS_PLUGIN_SUBDIR_REV ../../MacOS)
|
|
+ SET (DEFAULT_DATA_SUBDIR share/qgis)
|
|
+ SET (DEFAULT_PLUGIN_SUBDIR lib/qgis/plugins)
|
|
+ SET (QGIS_PLUGIN_SUBDIR_REV ../../..)
|
|
SET (DEFAULT_INCLUDE_SUBDIR include/qgis)
|
|
|
|
ELSE (APPLE)
|
|
@@ -496,13 +487,12 @@ ENDIF (ENABLE_TESTS)
|
|
|
|
IF (APPLE)
|
|
# must be last for install, so install_name_tool can do its work
|
|
- SUBDIRS (mac)
|
|
ENDIF (APPLE)
|
|
|
|
# manual page - makes sense only on unix systems
|
|
-IF (UNIX AND NOT APPLE)
|
|
+IF (UNIX)
|
|
INSTALL (FILES qgis.1 DESTINATION ${QGIS_MANUAL_DIR}/man1)
|
|
-ENDIF (UNIX AND NOT APPLE)
|
|
+ENDIF (UNIX)
|
|
|
|
INSTALL(FILES cmake/FindQGIS.cmake DESTINATION ${QGIS_DATA_DIR})
|
|
|