pkgsrc/net/avahi/patches/patch-ai
rodent d1079112d5 Support more PKG_OPTIONS for the net/avahi package. This enables the user
to build the avahi UI with GTK3, which is required for some packages like
libepc. Commented patches. Removed dependency on desktop.mk, as the file
doesn't have a MimeType key. Only PKG_OPTION enabled by default is gtk2.
Thus, you will notice no difference in this version and the last (unless
you start enabling options). Bump PKGREVISION. Resolves PR pkg/47483
2013-04-21 00:58:46 +00:00

18 lines
533 B
Text

$NetBSD: patch-ai,v 1.3 2013/04/21 00:58:47 rodent Exp $
Check lower bounds on port.
--- avahi-core/server.c.orig 2010-06-29 18:51:53.000000000 +0000
+++ avahi-core/server.c
@@ -903,6 +903,11 @@ static void dispatch_packet(AvahiServer
return;
}
+ if (port <= 0) {
+ avahi_log_warn("Received packet from invalid source port.");
+ return;
+ }
+
if (avahi_address_is_ipv4_in_ipv6(src_address))
/* This is an IPv4 address encapsulated in IPv6, so let's ignore it. */
return;