pkgsrc/security/zoneminder/patches/patch-Makefile_am
dsainty 3205b33802 Update ZoneMinder from 1.25.0 to 1.28.1.
Numerous changes, documented at:
 https://github.com/ZoneMinder/ZoneMinder/releases

Addresses two security advisories:

  https://github.com/ZoneMinder/ZoneMinder/releases/tag/v1.28.0
  http://secunia.com/advisories/62918/

Pkgsrc changes:

patch-src_zm_signal_h is no longer necessary because zm_signal.h uses
HAVE_EXECINFO_H.

patch-src_zmf_cpp appears to be applied upstream.

patch-configure_ac no longer needs to set PATH_BUILD to
PREFIX/share/zoneminder, so that zmupdate.pl can locate the database build
scripts as installed files.  Upstream has now implemented this via the
ZM_PATH_DATA entry in zm.conf, and adds a ZM_PATH_DATA/db subdirectory.

src/Makefile.am no longer setuid's zmfix, as zmfix was removed from
ZoneMinder 1.26.6.

The code now uses clock_gettime(), which on some systems (like Linux), calls
for -lrt.  Since the build system isn't aware of this, but Pkgsrc is, just set
PTHREAD_AUTO_VARS=yes.

The PHP code now uses PDO for DB access, but it looks like there are some
straggling dependencies on the raw MySQL driver, so both are pulled in.
2015-04-05 08:51:08 +00:00

27 lines
1.1 KiB
Text

$NetBSD: patch-Makefile_am,v 1.3 2015/04/05 08:51:08 dsainty Exp $
Disable the hacks around ownership setup so Pkgsrc can take responsibility.
Don't install zm.conf at all - let Pkgsrc install it into EGDIR.
--- Makefile.am.orig 2011-05-20 09:39:37.000000000 +0000
+++ Makefile.am
@@ -5,8 +5,8 @@
webgroup = @WEB_GROUP@
zmconfigdir = @ZM_CONFIG_DIR@
-zmconfig_DATA = \
- zm.conf
+#zmconfig_DATA = \
+# zm.conf
SUBDIRS = \
src \
@@ -20,7 +20,7 @@
zmconfgen.pl.in
# Yes, you are correct. This is a HACK!
-install-data-hook:
+pkgsrc-disabled-install-data-hook:
( cd $(DESTDIR)$(zmconfigdir); chown $(webuser):$(webgroup) $(zmconfig_DATA); chmod 600 $(zmconfig_DATA) )
( if ! test -e $(DESTDIR)$(ZM_RUNDIR); then mkdir -p $(DESTDIR)$(ZM_RUNDIR); fi; if test "$(DESTDIR)$(ZM_RUNDIR)" != "/var/run"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_RUNDIR); chmod u+w $(DESTDIR)$(ZM_RUNDIR); fi )
( if ! test -e $(DESTDIR)$(ZM_SOCKDIR); then mkdir -p $(DESTDIR)$(ZM_SOCKDIR); fi; if test "$(DESTDIR)$(ZM_SOCKDIR)" != "/var/run"; then chown $(webuser):$(webgroup) $(DESTDIR)$(ZM_SOCKDIR); chmod u+w $(DESTDIR)$(ZM_SOCKDIR); fi )