pkgsrc/devel/libslang/patches/patch-ad
jlam 4c2fe71631 + Pass down the correct values for TERMCAP (the options to link to
the library containing termcap functions) and MISC_TERMINFO_DIRS
  (the location of the terminfo database).  Patch the configure script
  to use these values instead of using its own broken logic to determine
  the same information.

+ Include termlib.buildlink3.mk to determine the right terminal library
  to use.

The above two changes should fix PR pkg/30725.

+ Move the HTML documentation into ${PREFIX}/share/doc/slang.

Bump the PKGREVISION to 6.
2008-02-29 16:44:55 +00:00

22 lines
516 B
Text

$NetBSD: patch-ad,v 1.1 2008/02/29 16:44:55 jlam Exp $
--- src/sltermin.c.orig 2003-03-23 02:06:40.000000000 -0500
+++ src/sltermin.c
@@ -220,14 +220,13 @@ static char *Terminfo_Dirs [] =
{
NULL, /* $HOME/.terminfo */
NULL, /* $TERMINFO */
+#ifdef MISC_TERMINFO_DIRS
+ MISC_TERMINFO_DIRS,
+#endif
"/usr/share/terminfo",
"/usr/lib/terminfo",
"/usr/share/lib/terminfo",
"/etc/terminfo",
- "/usr/local/lib/terminfo",
-#ifdef MISC_TERMINFO_DIRS
- MISC_TERMINFO_DIRS,
-#endif
""
};